Preferences/Advanced Files and Folders All Disabled

edited March 17, 2023
I have a new install and I can't set the Base Directory or Data Directory location the files and folders screen is disable. I have tried renaming and deleting the Zotero directory that gets automatically created. I turned off sync as well to stop default directory from being populated.
  • edited March 18, 2023
    Can you take a screenshot, upload it somewhere (Google Drive, Dropbox, etc.), and provide a link here, and also provide a Report ID? There shouldn't be anything in a stock Zotero install that would cause those to be disabled.
  • Here's the path to the image -

    Here's the error report:No errors have been logged since Zotero started.

    version => 6.0.23, platform => Win32, oscpu => Windows NT 6.2; WOW64, locale => en-US, appName => Zotero, appVersion => 6.0.23, extensions => Zotero LibreOffice Integration (6.0.4.SA.6.0.23, extension), Zotero Word for Windows Integration (6.0.3.SA.6.0.23, extension)

    I can try and click either choose button and it does nothing, same with custom selector.
  • Have you checked that the folder picker isn't just appearing behind Zotero? Are you using any other add-ons?
  • Yes double-checked the windows aren't there. No other add-ins. It's a brand new install. Running as Admin as well.
  • The buttons don't appear to actually be disabled. Security software or something else on the system may just be preventing Zotero from opening a file picker. (You also appear to be running Windows 8, which most people aren't running anymore, so there could be some unknown problem there.) I'm afraid that's all I can tell you.
  • Running as Admin as well.
    As in, you're running as an admin user, or Zotero is set to run as administrator? The latter should never be the case.
  • Smiling. It's not Windows 8, Windows 11 Pro. I'm going to look deeper into the security piece. Thanks for prompt replies. I've installed Zotero on at least 4 machines and never had the issue.
  • I'm the admin user and just tried to run Zotero as admin to see if it would enable the screen. I setup another admin user, curious, and that user (local) it works correctly.
  • edited March 19, 2023
    Interesting, base on your discussion, I modified the prefs.js in appdata:
    user_pref("extensions.zotero.dataDir", "D:\\MyDrive\\Zotero");

    Still can't modify from the Files and Folder screen, but it found my Zotero database.
Sign In or Register to comment.