[Solved] Cannot find zotero.sqlite files while backing up

edited February 7, 2023
After a couple of months since my last backup on Usb, I could not retrieve sqlites files in my Desktop documents and program files.

But everything works fine, all the other folders and files are here, Zotero desktop is working fine with all my tags, annotations, etc.

First Zotero version downloaded after 2019, now using the beta.

What I tried so far is to search for zotero.sqlite and sqlite in both My Documents, Program File, the Zotero-beta dedicated folder, the Zotero by-default dedicated folder (in program file I remember well).

My guess is that instead of copying I might have moved zotero.sqlite file on my last backup on Usb stick. But this is strange as I could still go on with my tags and normal routine on my desktop library (add article from web, annotate, create notes...).

Beside asking what happened and what to do : is copying an old zotero.sqlite back in Zotero folder is a bad idea? I thought it could break some stuffs...


Edit: I found it after closing and re-opening my library, locate a random file.
  • I'm not really sure what you mean here. Your Zotero data is in your Zotero data directory — not My Documents, not Desktop, not Program Files, not anywhere else. If you see your data when you open Zotero, you have a zotero.sqlite with your data in your data directory.
  • Yep sorry, I meant I checked in the corresponding folders. Anyway everything is solved and at place thanks.
Sign In or Register to comment.