Does JSTOR block Zotero? Stable URL not working to load citation

Hello, I have been teaching a class to use Zotero with university library resources.

Today we are using JSTOR. Students have repeatedly found instances of stable URLs that are not capable of being identified by Zotero.

The error message is: "Info. Zotero could not find any identifiers in your input. Please verify your input and try again."

Here's one URL that doesn't work -

I have also tried these URLs in zbib and they won't work there either.

Why are JSTOR stable URLs not providing information to create a citation?

  • Note: I've been teaching Zotero use with JSTOR for years and have never before encountered this problem.
  • Note: Now students are showing that stable URLs from JSTOR are sometimes resolving to incorrect citations created in Zotero.
  • edited January 19, 2023
    I think there's some confusion here. Are you asking about Add Item by Identifier, or saving from the JSTOR site with the Zotero Connector?

    The latter should work fine, and does for me. It doesn't work in ZoteroBib, likely because JSTOR blocks requests from cloud servers — not specifically Zotero. And there's nothing we can do about that, unfortunately.

    But pasting a JSTOR URL into Add Item by Identifier has never worked, because Add Item by Identifier isn't for URLs. If anything Zotero might parse the number as a PubMed ID and import the wrong item from that.

    The way to save JSTOR articles to Zotero is to go to the site and click the Zotero Connector's save button, as with any other supported site.
  • Please do always mention when you talk about the web library: Zotero without qualifiers is assumed to be the desktop app, where URLs have never worked as identifiers and where import of JSTOR articles via browser connector continues to work fine. I'm seeing the same issue in the web library & zbib, though, with Zotero returning a server error (500) under the hood, which suggests something broken there.
  • I guess you're actually talking about Add by Identifier in the Zotero web library. That does support URLs, but it's the same situation as ZoteroBib — some sites may block cloud servers. You can still save from JSTOR to the web library using the Zotero Connector, even if you're not using the desktop app.
  • Apologies.

    However, the problem persists in both the web library and the desktop app.
  • In the desktop app using the connector? URLs won't work, ever, in the add by identifier window in the desktop.
  • @dstillman with respect, I have taught this module for several years using the web library and previously JSTOR stable URLs have always resolved into citations using the "add by identifier function"

  • Very much possible, but sites change their policies/behavior and if JSTOR wants to prevent cloud services from accessing their metadata, they can do that pretty effectively and, as dstillman says, not much Zotero can do about that. That's why you have other options.
  • @jowellsatiusb: Again, Add by Identifier in the web library and Add Item by Identifier in the desktop app are separate things, and Add Item by Identifier in the desktop app has never, ever, supported URLs. I didn't know you were referring to the web library because you didn't actually say so.

    In the web library and ZoteroBib, JSTOR URLs won't work because JSTOR blocks web requests from the Amazon cloud. This is the error:
    HTTP request to rejected with status 403
    (403 means Forbidden.)

    Whether this is new or not I couldn't say — I somewhat doubt it, because JSTOR has for years been wary about bots. But there's nothing we can do about it in any case.

    Again, though, you can always save from JSTOR or any other supported site using the Zotero Connector, including direct to the web library without the desktop app.
  • Thank you. That's why I titled this discussion "Does JSTOR Block Zotero?" This is a new issue to me.

    Also, the issue is by no means wholly consistent. Many JSTOR stable URLs are resolving correctly as I have seen them do in the past.

    Furthermore, the fact that some JSTOR stable URLs are resovling to incorrect citations at other JSTOR stable URLs indicates that JSTOR's block is incomplete.

    I guess I'll just quit using JSTOR for this aspect, it's obviously their fault.
  • Thanks for the insights, both of you!
  • Requests from the web library and ZoteroBib would come from various IP addresses, and they may only detect some of them as being cloud IPs, which could explain why some are allowed. I'm not sure why you'd be seeing incorrect results — that shouldn't happen regardless, but hard to say more without an example.
  • @jowellsatiusb: We've made a change that, at least for now, allows items to be saved by JSTOR URL from the web library and ZoteroBib. (It looks like they were actually blocking based on user-agent string, not cloud IP address, and a newer browser user-agent string fixes the issue.)

    Based on another thread, I'd guess that the ones that were working for you included a DOI in the URL, which would've been saved via DOI metadata if direct saving from JSTOR failed.
Sign In or Register to comment.