Word bibligraphy has citations that don't seem to be in library

I have a word document with zotero bibliography that has entries that I cannot find in my zotero library. The word doc was originally mendeley, but now it's zotero. Is this something that others have experienced? Is there a way to troubleshoot this? For example, in the bib, I have this entry:

Chen, A., Lu, Y., Chau, P. Y. K., & Gupta, S. (2015). Classifying, Measuring, and Predicting Users’ Overall Active Behavior on Social Networking Sites. Journal of Management Information Systems, 31(3), 213

But a search of all fields and tags of my library doesn't turn anything up. What's interesting is that if I delete the bibliography and readd it, it shows up in the bib, matching the in-text citation.

What's up with that?

  • Zotero is able to read (and then cite) Mendeley citations, but you indeed don't see them in your library nor can you modify them -- I suspect that's what's going on here (Zotero will also store reference information in the Word doc, so you could have deleted the item in Zotero, but that seems less likely here).

    What to do for troubleshooting depends on what the actual trouble is -- what do you want to happen?
  • edited September 10, 2020
    That makes sense. I like it that it didn't demolish things when I started using Zotero against this word doc, but it's still not a great idea to switch between citation managers (or share with someone using a different one) as things can get out of sync.

    On the troubleshooting front, it'd be swell if you could place your cursor in a citation or bibliographic reference and navigate to the corollary in the doc and in the database. i.e. have a right click menu ->show citations / -> show bib / show zotero entry... Tall order, I'm sure :)
  • When an item _is_ in you Zotero library and cited from there, you can. After clicking "Add/Edit citation" with your cursor in the citation, the red citation bar opens, click on the author/year for the citation in question and there'll be an "Open in Library" button.

    To see if an item is Zotero or Mendeley, you can toggle field codes -- they look a bit different for the two: https://www.zotero.org/support/kb/word_field_codes
  • OK. Sounds reasonable. Consider this Solved :).
  • Good morning,
    I am working on a word document in which I had entered sources via Zotero.
    I now realise that some Zotero sources (active field codes) appear in the document but no longer exist, I don't know why, in my personal library.
    Is there a way to update the personal library in the Zotero application to include those Word sources that no longer appear there?
  • You can use this tool: https://rintze.zelle.me/ref-extractor/

    However, if you duplicate items after using it make sure to merge them before to not create more problems down the line.
  • thank you very very much
Sign In or Register to comment.