Dragging articles to collections is slow

If I click on an article and drag the mouse, this operation is not immediately registered and I have to wait for several seconds before the shadow of the article appears under the mouse.
If I move the mouse over a collection and release the mouse button before the shadow appeared, the article doesn't get copied to such collection.
If I drag the article over a collection, wait several seconds for the shadow to appear and then release the mouse button, then the article is copied to the collection.
The same happens if I press the shift button before dragging in order to move the article.

I would expect the shadow to appear under the cursor immediately (in Linux it does)

Operating system: Windows 10 Pro
Zotero version: 6.0.9
Addons: BetterBibTex, Zotero Tag, DOI Manager, Libreoffice and Word integration
  • It should be immediate, unless perhaps you have a massive number of items in that collection.

    Can you reproduce this with all third-party plugins disabled? If so, can you provide a Debug ID for this?
  • I had this issue recently and after disabling BetterBibTex and restarting Zotero it dissappeared (I enabled BetterBibTex again afterwards and I've had no issue since). Perhaps try that?
  • I disabled all the addons and this problem disappeared, thus it's related to one of those addons I am using and not to core Zotero.
    I then enabled the addons one by one but I was unable to obtain the same behaviour.
    Definitely its one of those three addons causing the problem, but I'm unable to determine which one.
  • edited July 26, 2022
    When BBT is involved, it seems to have something to do with the BBT translators not being considered loaded, but I have no idea

    1. why BBT is getting in the way when the quickcopy translator is not a BBT translator
    2. how to force BBT translators to be preloaded
    This didn't use to be a problem because a restart would preload the BBT translators too, but I have seen users where this did not happen, so for them the problem is permanent.

    edit: question about this on zotero-dev here.
  • edited August 11, 2022
    Thank you all for the suggestion on disabling and re-enabling BBT. I also had the same problem, which disappeared after following said steps.

    Edit: OK, perhaps I was too fast :). As soon as I selected BetterBibTex as the default export format, the problem reappeared.
  • I still don't know how BBT triggers this behavior.
  • @emilianoheyns Ok, if there's any way I can help to debug this, let me know.
  • @dstillman any tips on how to make sure my translators are pre-loaded? As far as I can tell that is part of the problem; after a reinit of the translator framework my translators are not loaded. I test at start whether my translators need to be reinstalled (and skip install and reinit if not needed), so a restart after upgrade used to set things straight, but for some users the query whether my translators are installed always gets back "no", so I reinstall + reinit at every start, etc.
  • I'm also working to speed up loading of the BBT translators: https://github.com/retorquere/zotero-better-bibtex/issues/2265
  • Speed upgrade achieved.
Sign In or Register to comment.