Zotero chrome connecter is not working after updating to Zotero version 6

1. An example of URL that is not being saved to Zotero Standalone version 6
https://www.ncbi.nlm.nih.gov/pmc/articles/PMC3563387/#:~:text=Definitive diagnosis of invasive fungal disease relies on microbiological and,of probable invasive fungal disease.

2. Debug ID

3. What it says in the popup when you try to save
Save to Zotero (Pubmed Central)
  • Thanks, on it. (It looks like this is the result of some recent design changes on PubMed's end.)
  • Yes. Importing from PubMed Central has been unreliable for a couple of days.

    An easy temporary solution is to follow the PMID link and import directly from PubMed.
  • @DWL-SDCA: Has it worked at *all* for you since it started becoming unreliable a couple days ago? I’m trying to figure out if the API we’ve historically used for PMC is down permanently or just having issues during this upgrade.
  • I don't know if this will be helpful but here is what I've experienced: It has not worked for me for the entire day. It did work properly with Zotero on Tuesday. It didn't work yesterday afternoon at all (but although I'm not sure, PMC and Zotero may have cooperated earlier in the day on Wednesday. I can't say more because I don't usually use PMC and only when there is no abstract in the PubMed record and I want to use PMC to find full text to write my own summary. That is uncommon. The last few days, I've connected to PMC via links from Google Scholar Alerts.
  • I don't see any indication that this is changed or removed in eutils -- the API basically never changes (last change was in 2015). The error message I'm seeing ( bePMCXML (%23PmcXmlSrv): Couldn't+resolve+%23PmcXmlSrv,+the+address+table+is+empty.)
    looks like an error on their end to me -- I'd try reporting.
  • edited July 15, 2022
    I'm sure that it is an error on their end -- this morning I received a reply to my tech-help request acknowledging the problem and saying that they will fix it soon. In my experience, the NCBI help desk is always very responsive and almost always replies within 24 hours. In my messages above I didn't mean to suggest that this had anything to do with Zotero.
  • Alright, good. I do think we'll still need to update the way we pull PDFs since that's changed on the new site, but if our existing API is staying then that makes things a lot easier.
  • @DWL-SDCA Any idea if this is supposed to have been resolved yet? As of a few minutes ago, Connector is not currently succeeding at pulling the PDFs from either PubMed or PMC. Example URLs:

    Both just created an item but the PDF download failed (no error message).
    Note: the PDF was pulled successfully from the publisher's page: https://www.pnas.org/doi/10.1073/pnas.2011226118?url_ver=Z39.88-2003&rfr_id=ori:rid:crossref.org&rfr_dat=cr_pub++0pubmed
  • I was commenting on the now resolved issue concerning PubMed Central. I don't normally download PDF files when I download the metadata (even when I have free access to the full text file).
  • There's an issue with PDF download from PMC, apparently. Nothing to do with the rest of this thread.
  • PMC PDF download is now fixed, should update for you shortly.
Sign In or Register to comment.