Cannot move items or collections from My Library to Group Libraries

I am trying to move an item from "My Library" to a Group Library, in the Zotero Standalone client on Linux (Zotero version 6.0.10).

When I drag the item (or even a collection) to the group library, I get a "+" like icon as soon as I hover the dragged item over the name of the group library in the left plane. However, when I release the mouse button at this point, nothing happens: the dragged item is not moved to the target Group library.

This same drag and drop process works perfectly when I drag an item to a collection in the same library. The documentation at ( suggests that the same process should work across group libraries as well: "Items can be dragged into a group from My Library or another group and viewed or edited by other group members, if their permissions allow it." I have checked that I have write access to the group libraries I am trying to edit: I can create items in them using the Zotero connector, or the arxiv/DOI wizard, for example.
  • Can you create a completely new item in your library and try to drag that to the group? (and yes, this should work)
  • Thanks for the tip. I did some more digging and here is what I found.

    Originally, I was trying to move a large collection and that wasn't working. Then I tried exactly what you suggested (create a new item, and move it by dragging), and that also *did not* work.

    Then, I restarted Zotero with debug output enabled. Now suddenly, copying individual items by dragging started working. I could even copy a few smaller collections by the same drag-and-drop method. To try my luck further, I tried copying the same large collection. Now, in the debug window, I could again see a lot of SQL like commands, but it ended with a message like the following:

    (1)(+0000137): Rolled back DB transaction QGPGEsRZ

    and the large collection was not copied to the group library.

    So the current status is that I can copy individual items and some collections, but often on collections containing a large number of items and/or subcollections, the drag-and-drop starts copying, but then stops with a rollback like the above.
  • Can you provide a Debug ID for an attempt that fails, after restarting Zotero?
  • Yes, Here is a debug ID from a failed drag-and-drop operation: D584137681
  • Hmm, bizarrely nothing at all is getting logged there for an error.

    Can you restart Zotero and provide another Debug ID for triggering this again, to see if it happens at the exact same spot?
  • @piyushsriva: This should be fixed in the latest Zotero beta, and the fix will be included in Zotero 6.0.12 soon. No need for further info.
Sign In or Register to comment.