Zotero crashes Word in Microsoft Office build #2207

edited August 5, 2022
I love Zotero. It has worked flawlessly in Microsoft Word for years through my PhD until Microsoft's system update on July 12, 2022, to build Version 2207 (Build 15427.20194 Click-to-Run). Since then, anytime I try to Refresh or Update citations in Zotero using the Word add-in, it crashes both Zotero and Word. I have tried all of the suggested Zotero fixes and nothing changes. It crashes every time. I have a different computer at work that has not yet applied the Microsoft Office update and is still running Version 2206 (Build 15330.20264 Click-to-Run), which continues to run Zotero flawlessly even with my 200-page manuscript. I am desperate to get the manuscript to the publisher and reviewers (and can't work on it at work for intellectual property rules). Please help!

I am running Windows 10 Education 64-bit version 21H2 OS build 19044.1826 and Microsoft 365 Enterprise on both computers, both of which have the latest Intel processors and 32 gig of RAM. I'm also running the latest version of Zotero, 6.0.10 and have reinstalled the Word add-in's multiple times.

Report ID: 2139380932

[JavaScript Error: "The RPC server is unavailable.

[JavaScript Error: "The RPC server is unavailable.

version => 6.0.10, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 6.0.10, extensions => Zotero LibreOffice Integration (6.0.0.SA.6.0.10, extension), Zotero Word for Windows Integration (6.0.0.SA.6.0.10, extension)
  • Can you refresh your manuscript on the same computer in a new Windows user account? See step 11 in Troubleshooting Errors in Word Processor Documents if it crashes even in a new user account.
  • edited August 9, 2022
    Thank you for the suggestion. I have tried isolating the error as mentioned in the Troubleshooting link (is that the Step 11 of which you were speaking?). Zotero and Word crash whether it's in my large manuscript, portions of my manuscript, or even a new document with only two citations. As for using a different Windows user account, I have only one Windows user account on each computer.
  • Try disabling all other Word extensions except for Zotero on the computer that is causing issues. If that doesn't help can you create a new user account for testing and see if it works fine there?
Sign In or Register to comment.