How to use DOI for "Add Item(s) by Identifier" ?

How is one supposed to use a DOI for the "Add Items by Identifier" dialogue? I tried all these three:

- doi:1721.1/110380
- 1721.1/110380

but all of them were rejected with "Zotero could not find any identifiers in your input." (The 2nd form (URL) does work on web browsers.)

Zotero 6.0.9
macOS 12.4

  • This identifier is not a DOI, all DOI prefix must start with 10. (see
    It appears that can also resolve non-DOI handles? Interesting, I didn't know that. But clearly the Crossref API cannot retrieve metadata from those identifiers.

    Anyway, you will be able to import the reference by visiting the resource page and using the Zotero browser connector - so I suggest doing that instead :-)
  • edited July 5, 2022
    That's a handle, not a DOI. DOIs begin with "10.".

    DOIs are based on the handle system, but they're not the same thing. Handles provide persistent links — which is why the redirect works for the above link — but there's no metadata available for them for Zotero to look up.
  • > That's a handle, not a DOI. DOIs begin with "10."

    Thank you for the valuable information!

    In that case, my request would be to alter the error message from Zotero.

    I obtained the handle from a web page written by the authors of the document and the handle was written as "doi:1721.1/110380" .

    Technically this is a wrong representation of the handle, but who would know these technicalities?
  • edited July 5, 2022
    Huh? The error message was accurate — there were no known identifiers in the field. You can paste any gibberish into there. Complain to the authors for calling it a DOI.
  • @dstillman

    > The error message was accurate

    I agree 100%. But, it is also true that it's NOT INFORMATIVE to an ordinary user.

    Whether it's TECHNICALLY accurate is very different from whether it's informative.

    A "handle" behaves exactly like a DOI from an ordinary user's point of view. She will not know it's not technically a DOI. That must be the reason why the authors in question posted the handle as a DOI.

    Then she pastes what she THINKS is a DOI into the box of Zotero and wonders why it doesn't work.

    So, my proposal is: Instead of "Zotero could not find any identifiers in your input", what about saying something like "This is actually not a DOI; it's called a handle ()".
  • edited August 3, 2022
    But that's not something Zotero knows. It just knows that the thing you pasted is none of the various identifiers (ISBN, DOI, PMID, arXiv ID) it is able to import (which is, accordingly, what the error message says). It could theoretically infer that *you* thought it was a DOI because of the prefix, but most people paste DOIs without the doi: prefix (that's what you appear to have tried first, too), so that'd be writing special error code for *very* specific scenarios that wouldn't actually help many people .
  • @adamsmith Thank you for your comment!

    > most people paste DOIs without the doi: prefix

    If that's the case, I agree with you: Trying to guess that the pasted code may be a doi handle would be overkill. But it may be still useful to detect the case when "doi" prefix *is* present. I for one certainly include the prefix "doi:" because I just don't know how similar ISBN, DOI, PMID, arXive ID, etc. are.
  • edited August 5, 2022
    Please don't take this as my being rude or judgmental but you would derive great benefit from spending 15 minutes or so reading descriptions of each of these identifiers. edit: you can find this info about each identifier on Wikipedia.

    Often, when a real DOI is not recognized by Zotero it is because the publisher presented the string with a systematic error. Even with limited knowledge of the format-standard you can very quickly recognize the problem and correct it. Perhaps, when doing a cut/paste of a DOI the beginning 1 of the 10 wasn't copied. Upon quickly recognizing this the missing character can be added. (Alas, some publishers and literature databases [e.g. CNKI] use correctly formatted DOIs but house the metadata in a registry that isn't currently available to Zotero -- or to any other reference manager.)

    edit :
    I deal with one eastern European publisher with metadata that omits the dot after the 10. I know I can fix it by adding the punctuation and then successfully import the record. Some publishers include spaces within their DOI strings. When I see these I remove the spaces and the concatenated DOI will properly import. These publishers do not provide any metadata with their webpage headers nor do they offer things like RIS export that allow a Zotero translator to function. In each case the metadata they provide to their DOI registry is not necessarily great (all author first and last names in one single very long field etc often with Roman and non-Roman (name) characters strung together, etc.) Even with the recognized problems, there is less editing effort required than if I had to hand-enter everything.
Sign In or Register to comment.