Adding by Identifier seems to be stuck (iOS Beta)

edited August 2, 2022

I tried to add a publication by identifier (ISBN and DOI) and it seems to look for it but never returns a result.

Also, at first the input field seems to be covered by the iOs word suggestion bar. After a first search attempt without an entry the input field ends on top of the screen.

Anyway, big fan of zotero ios (and desktop!)
  • edited August 2, 2022
    This is the iOS beta? (Be sure to note both of those things in your thread titles.)

    What identifiers are you trying? Can you provide a Debug ID for an attempt that hangs, after force-quitting the app?

    For the other thing, can you take a couple screenshots, upload them somewhere (e.g., Dropbox or Google Drive), and provide a link here?
  • Sorry about that. Added it.

    I tried ISBN and DOI.

    Debug ID: D376927455

    Here’s a link:

  • edited August 3, 2022
    That's working fine here. Your Debug ID doesn't show the add attempt. You can check the instructions and try again, making sure you're logging the attempt in question?

    Also note that there's no reason to remove the The app will parse out the DOI.

    (Also, please post the identifiers you're trying here so we don't have to retype them from videos.)
  • mh, just noticed that i’m not in the beta program anymore. maybe I was not on the most current version?

    How could i apply for the beta again?
  • edited August 3, 2022
    Sorry, you are indeed not on the latest beta version.

    You should be able to upgrade from TestFlight. If you don’t see it:
  • yah, after enrolling and installing the beta again it works!

    sorry for the unnecessary detour.

    Happy to have adding by identifier available on iOS!
Sign In or Register to comment.