Zotero stuck in the updating document in Google Docs After enabling new integration

Report ID: 1938773882
(Using Chrome on Windows 10)

A few days ago I made a copy of my dissertation. It is a google doc that had citations and after I made that copy and tried to add new citations, it would say updating in the footnotes (for clarity, I was able to enter the citation info and pressed enter as usual, but the citation never populated in the doc and it just said updating). I'd had this happen randomly for a while, but usually I could delete the citation and when I reentered it, it would pop up correctly. After making the copy of the doc it didn't help to delete and reenter. Unfortunately I didn't check if it was only that document before I ran into my current issue. Forum advice said that I should enable the google docs integration v2. I did that and refreshed the google doc, but when I did that point I could do nothing. When I tried to add citation or look at document preferences there was a little flicker on my screen like it was trying to do something, but nothing happened. I tried removing the chrome extension and reinstalling it from a new download with no success. I then restarted my computer because I know that's usually helpful. Now when I try to add a citation I can't even get to the screen to add the citation info. It is stuck on the 'progress' window. Zotero does work on Word, but it would make my life more complicated to have to continuously switch between Word and Google Docs. Any advice?
  • When I tried to add citation or look at document preferences there was a little flicker on my screen like it was trying to do something, but nothing happened
    Are you sure the citation dialog wasn't just appearing behind your other windows? That's usually what's happening in situations like this. It's a Zotero window, so check behind your main Zotero window.

    If you don't think it's that, we'd want to see a Debug ID from Zotero for this after restarting your browser and Zotero.

    After providing that, to try to fix this quickly, I'd disable v2 for now, try disabling any other browser extensions, and if you're still having trouble try in Firefox.
  • I know this. I've been using Zotero for years. Even when I go behind the other windows it just stays on the progress bar and never moves onto the dialog box where I can add my citation info.

    I wasn't sure whether you wanted the debug id from Zotero or from the extension so here are both:

    Extension: Report ID: 1560263069
    Zotero: Debug ID D1890189189

    I tried to disable v2 already and it broke everything to the point where Zotero didn't respond to anything, so I am going to see if I can use firefox for now
  • edited August 1, 2022
    That Debug ID from Zotero doesn't show any attempt to use the plugin in Google Docs.

    Can you try again, and also provide a Debug ID from the Zotero Connector? (You provided a Report ID, which isn't the same thing.) Be sure to restart Zotero and your browser before generating these, and make sure you log the operation in question.
Sign In or Register to comment.