WebDav sync 4shared not working in Zotero iPad

Hi all,

While b-testing the app, I reported a problem syncing files stored in the 4shared WebDAV server (https://forums.zotero.org/discussion/comment/394088#Comment_394088). After trying to save it, I gave up waiting for the final app to be up and running for several months. I have now installed the app from the App Store, set the WebDAV server, and tried to download a paper. However, the problem remains: "The attached file could not be found" (DEBUG ID: D2141202302).

I have also tried sending PDF files from safari to Zotero on the iPad. Unfortunately, it also gives an error: " An unknown error occurred," and in a second go, "Could not find file to upload" When I check the app's local storage, it seems that the file is there; however, it can't be uploaded to the server.

I don't know if this is a problem with the 4shared server and iPad, but with the Mac, it works perfectly. If so, I would love to know which WebDAV server works well.

I would appreciate it if you could help me with this.

  • If you do a Verify Server in the desktop app, do you see a warning that a file wasn't available after an upload, with an option to proceed anyway? This can happen on WebDAV servers where there can be a slight delay before uploaded files can be downloaded.

    That's what's happening for you in the iOS app, but we may not yet show the same prompt there. We'll look into this.
  • If I do the Verify Server on the desktop app, I get the warning you indicate. However, the files sync.

    I have entered my 4shared Zotero folder and tried to download a file. It turned out surprisingly slow, no matter the internet connection (I have tried three different connections with a decent download speed). So it looks like this server speed may be OK for the desktop app. Since the desktop app is always active, it has more time to upload and download from the 4shared slow server. However, this turns out to be critical for the iPad download.

    As an alternative, I have set my WebDAV server on my Synology NAS, and everything is now working smoothly.

    @zotero team: thanks for this fantastic app
    @dstillman: thanks for your help.
  • It's not about download speed. It's what I say above — that the file isn't immediately available for download after upload, and we don't yet support servers with that behavior (which is technically a violation of the HTTP spec) on iOS. But glad you got it working with another server.
Sign In or Register to comment.