Zotero App not able to sync on my Windows computer, Works ok on Linux computer

edited June 23, 2022
Hi this is my first discussion, so I hope I'm doing it right.

Syncing worked just fine on my Windows computer until about March.
Then it stopped working.
Can log in just fine from Firefox.
Can sync Zotero app on my other computer ( Linux ).

Now on Windows 10 box it won't sync.
Won't allow submission of debug dump.
Now it won't synch, and won't accept synch preferences.

Press "set up syncing" and it responds with:
An error occurred during a connection to api.zotero.org.

TCP connection reset by peer


[JavaScript Error: "An error occurred during a connection to api.zotero.org.

TCP connection reset by peer



[JavaScript Error: "The connection was refused when attempting to contact wss://stream.zotero.org/."]


[JavaScript Error: "API key not set"]


[JavaScript Error: "Zotero Error: An error occurred during a connection to repo.zotero.org.

TCP connection reset by peer

" {file: "chrome://zotero/content/debugViewer.js" line: 178}]


version => 6.0.8, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-GB, appName => Zotero, appVersion => 6.0.8, extensions => Zotero LibreOffice Integration (6.0.0.SA.6.0.8, extension), Zotero Word for Windows Integration (6.0.0.SA.6.0.8, extension)

[extra output removed — D.S.]
  • There's a problem with your networking setup — all network requests in Zotero are just failing for you. See Connection Error.
  • Hi, thanks for the fast response.

    Unfortunately, I have tried many things to solve this: re-installing Zotero standalone, disabling Kaspersky firewall, disabling Kaspersky VPN, changing proxy type from 5 to 4 to 0 and back. Nothing seems to change the behavior described in the original post.

    The problem first appeared in March, around the time I installed Kaspersky VPN, which may or may not be relevent. Before that, Zotero standalone was working fine for years.

    The Firefox connector works just fine without standalone running. I'm able to save web pages to my Zotero account and see them reflected on the Zotero.org web interface when I log in there.

    Not having any network problems with any other programs and I use a lot of programs: Libreoffice, Cloudberry S3, Amazon Music/Audible for Windos, Jetbrains Pycharm, Telegram. No problems in any other programs, just in Zotero standalone.

    Again it all works just fine over on my Linux machine, it's only on the Windows 10 machine that this problem has emerged.

    Anyway, if there is anything else we can do to analyze this issue please do let me know. My current workaround is to limit my Zotero activity to the web interface and Firefox connector.

    Thanks much

  • edited June 24, 2022
    Yes, it's almost certainly related to your VPN/security software. I'm afraid you'll need to debug this yourself. Connection Error has all the information we can provide.
  • edited June 24, 2022
    @eca: The only other thing I can say is that if you generate debug output for Zotero startup, we might be able to tell you if it's using some sort of proxy connection. You can copy the output and email it to support@zotero.org with a link to this thread. (But the proxy connection would be controlled by your system proxy settings and/or network.proxy.type, as explained on the Connection Error page.)
Sign In or Register to comment.