LibreOffice plugin problem

I am only able to install the LibreOffice plugin via manual installation (it says there's an error). The manual installation also brings up an error.

( { { Message = "C++ code threw N10jfw_plugin25MalformedVersionExceptionE: std::exception", Context = ( @0 } }

The buttons appear, but are non-responsive. I have tried the following, based on the Zotero troubleshooting advice and past pages:

1. Installed the older, possibly more stable 7.2.7 version of LibreOffice
2. Deleted LibreOffice profile and reinstalled.
3. Checked that a Java Run-Time environment was being used.
4. Installed and selected an older JDK (

One other symptom: In LibreOffice's extension manager, the status of the extension is shown as "unknown" and efforts to enable give the same error as above.

Any advice?

Many thanks!
  • Sorry, but you've tried all that we can suggest. You can still try an older version of LibreOffice or Java, but otherwise you'll have to seek support with LibreOffice since this is their bug -- none of the LibreOffice extensions would work for you.
  • @dwoodruff: If this is an Apple Silicon Mac, make sure you're running the x64 versions of both LibreOffice and the JDK.
  • Thanks for the replies -- I've tried now rolling back to LibreOffice version 6 but it's still not working; it's not a Silicon Mac.
  • Sorry, this isn't something we've ever seen before and isn't a problem in Zotero, so I'm afraid there's nothing else we can suggest. There's something specific to your system that's causing trouble here.
  • Helpful person on LibreOffice IRC chat confirmed its a LibreOffice bug (now filed). Has to do with the fact that the Java version identification returns a plus sign.

    So the solution was to roll back to an older version of Java -- I used Java 8 from Oracle, and that worked. I had to go into the Advanced settings dialogue in LibreOffice, and select that version of Java once I had installed it. After that I was able successfully to install the plugin and it functioned correctly.
  • edited May 20, 2022
    Oh, yeah, I can actually reproduce this with

    JDK 17.0.2 (still available from here) works fine, but if I select, I get this error on manual installation, and trying to cite crashes the document.

    Can you provide a link to the LO ticket?

    It was 17.0.3 that didn't work for me -- didn't try 17.0.2.
  • Looks like this fix has landed for LO 7.3.5. Thanks for reporting this to them!
  • This is fixed in LO 7.3.4, available now.
Sign In or Register to comment.