In Text Citation on Mac not working

Hi, I am teaching a summer research class. One of my students has a mac laptop and cannot get any in-text citation (not just APA 7th Ed) to work. We have tried shift + dragging to the document (word and google doc) as well as trying to insert in-text citation using the zotero program in microsoft word.

Instead of an in-text citation, it will insert the entire reference for the bibliography where the student would like a citation. We have tried uninstalling zotero, restarting her computer, and restarting zotero. Any tips on how to make her in-text citation work? Thank you.
  • I'd guess that they just haven't selected the correct style in the correct place. There's almost no chance these functions aren't working properly.

    For Shift-dragging, you have to set the style in the Quick Copy settings in the Export pane of the preferences.

    For the Word plugin, you have to set the style in the plugin's Document Preferences.

    Note that these aren't equivalent. If they're using Word or Google Docs, they'd want to use the plugin, not Quick Copy.

    If you think something's not working correctly, we'd want to see a Debug ID for the operation.
  • Could we see an example of what exactly you're getting when inserting a citation?

    And could you right-click (ctrl+click)--> toggle field code for the insertion with the Word add-on and either copy the contents of the Word field or take a screenshot, upload it to a free image hosting site (, Dropbox, etc.) and link to it here?
Sign In or Register to comment.