Zotero in Danish

Hey Zotero!

I'm having an issue that I can't seem to solve. I've of course tried to Google, but with no success.

I'm using the OSCOLA (Oxford University Standard for Citation of Legal Authorities), with no ibid in my word document.

It doesn't seem to be possible to have it make references in Danish, and I can't select a language in the settings for the OSCOLA version. (The option box is grey and inactive). It's possible to pick danish in the other available citation methods, so it seems to be a problem isolated to the OSCOLA reference system. I've of course tried to install more OSCOLA versions, but to no avail.

Can you help? I've used Zotero with OSCOLA in the past on this PC, so I'm not sure what happened.

References look like this:
[1] Joseph Lookofsky and Vibe Ulfbeck, Køb - Dansk Indenlandsk Købsret Studieudgave, vol 2014 (1st edn, Jurist- og Økonomforbundets Forlag), s.57.

(I want the"and", "vol" and "st edn" to be in danish.
  • Styles with a default locale set -- like OSCOLA -- have never allowed using a different one in Zotero. You'd have to modify the style (or use a different one)
  • I don't really understand this reply. What do you mean about default locale?

    By modifying the style do you mean selecting a different reference type like for example Oxford?

    I just want it to be in danish instead of english. I know it can be done since I wrote my bachelors project on this very computer, with the same word and zotero installed.
  • Note: I wrote my bachelors project two years ago, and now working on my thesis.
  • Sorry, but this really hasn't changed. Some citation styles are designed to be used in multiple languages -- Chicago Manual, APA, Vancouver are all examples of that. Most citation styles are fixed to a specific language. That's the case for OSCOLA, and has been the case for at least the last 8 years and Zotero has never allowed you to select a different language for those.

    So you can either pick one of the relatively few styles that work in all languages, pick a style intended for use in Danish, or you can modify OSCOLA. For the last option, see https://www.zotero.org/support/dev/citation_styles/style_editing_step-by-step for general instructions. Specifically, you'll need to remove default-locale="en-GB" from the top of the style.
Sign In or Register to comment.