Not able to right click or open PDFs

I just moved to a new computer (macOS to Windows 10). I have about 40GB on Zotero storage (which was transferred to the local computer through syncing) and about 40GB on Dropbox with Zotfile. Eventually I'd like to merge them into one repository but that's for another time.

Currently there are some (many) entries where right clicking does nothing. I can expand the view of the entry to see there is a PDF there, but double clicking does not open the PDF and right clicking does nothing. The problem does not seem to be correlated with the Date Added.

Any way to resolve this problem? Since I have a huge repository and some PDFs have been scanned in, I can't just start from scratch and re-import the PDFs either.

I have reinstalled Zotero several times, even clearing personal data in between, but to no avail.

Thank you
  • What exactly do you mean by "right clicking does nothing"? Are you saying no context menu appears, or something else?

    Can you provide a Report ID?
  • Thanks for the rapid response. By context menu if you mean the menu that usually pops up with the options {View PDF, View Online, Show File, ...}, then yes - that's what doesn't show up for many of my entries. My report ID is as follows:

    Report ID: 1435721606

    Thank you
  • edited June 15, 2021
    [JavaScript Error: "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIFile.initWithPath]" {file: "chrome://zotero/content/xpcom/file.js" line: 47}]

    [JavaScript Error: "Error: Unexpected value '/Users/[…]/Dropbox/Papers/Zotero_Data/[…].pdf'" {file: "chrome://zotero/content/xpcom/file.js" line: 56}]
    This shouldn't prevent the context menu from appearing or the file-not-found dialog from appearing, and we'll fix that, but you have linked files that still have the absolute paths from your Mac. If you want to access those on another computer, you need to assign a Linked Attachment Base Directory properly on the Mac, sync, and then set the LABD correctly on the new computer.

    If you no longer have access to the Mac, you'd have to use the Zutilo plugin to manually batch-edit the paths to turn them into Windows paths.

    Once you've resolved this, be sure to properly set a LABD so that this doesn't happen again.
  • I see... I missed that before. I still do have access to the Mac so I've made the link to the Dropbox folder and it's updating now.

    Given that I still have many files in /Users/{username}/Zotero/storage/, will that affect links to those PDFs?

    Thank you
  • edited June 15, 2021
    Stored files just work — that's why they're the default.
  • edited June 17, 2021
    Indeed they do. And defining the LABD on the original machine (mac) and syncing seemed to have fixed it - thanks a lot. Strange though that right clicking was disabled completely for them - I could understand if the PDF couldn't be opened but it seems that bibliography export etc. should have worked even if the file was not found. But in any case, glad the problem is resolved. Thank you so much - that's a huge load lifted!
  • Strange though that right clicking was disabled completely for them
    Yep, that's a bug, and we've opened a ticket to look into that.
  • This happened to me as well, but without ever touching a Mac machine.
    Report ID: 326696992

    This is weird to me, because I use an external PDF reader. It also does not open the PDF in external readers but it does on the built-in reader.
Sign In or Register to comment.