Verifying identifier

I have been trying to input DOIs and ISSNs and get the same repeated message:

"Zotero could not find a record for the specified identifier. Please verify the identifier and try again."

I have ensured that Zotero is updated, checked the troubleshooting steps, tried refreshing the page, and all else, but it continues to happen despite which DOIs are entered.
I have seen some previous threads saying that this issue has occurred on the past, and that the issue was an upstream one. Just checking that it is isn't potentially on my end.
Thanks so much.
  • Example DOI?

    Can you provide a Debug ID for getting the error?
  • edited April 27, 2022
    (Also, I assume you mean ISBNs?)
  • edited April 27, 2022
    tried refreshing the page
    Refreshed what page?
  • I am using Zotero from the desktop app.
    Of course, now DOIs appear to be uploading, but there is still trouble with ISBNs.

    Debug ID: D429441390

    Example ISBN: 978-1-76081-393-2

  • That ISBN just isn't registered with any metadata service. Google only shows a single result on the internet, from the NSW government website.
Sign In or Register to comment.