Zotero application bug report

Zotero for Mac has on several occasions today hung while annotating using the PDF reader. Restarting temporarily fixes it, but the issue recurs. The Report ID is 2045588702, and the Debug ID is D379931359.
  • Do you know exactly what you were doing when this happened? Do you have exact steps to reproduce it reliably?
  • Each time (I think three times so far) I was highlighting a PDF within Zotero. It triggered three times when I then tried to 'add to note' (with a standalone note). The document was already half-annotated, and would work for a few more annotations each time.
  • edited April 21, 2022
    What do you mean by "it triggered three times"? Do you use "Add to Note" more than once without getting a response?
  • Sorry, I meant the application crashed three times, each when I tried to 'add to note'. It may just have been something else going on my computer - it was having some difficulties yesterday so I did a number of cleanups and (touch wood) today it is working fine. However, I did notice yesterday (before I cleaned up) that it told me to restart Zotero when I added a note using the 'Add to note' option that pulls up when right-clicking, but when I dragged the same annotation to a note it worked fine. I'll report back if it happens again.
  • Unfortunately, this has now recurred - again, it seemed to be triggered by using the 'Add to note' option on right-click. It generated a Report ID 319762837, but when I tried to restart with debug output logging, it crashed. Force-quitting, restarting, and uninstalling and reinstalling the latest version also hasn't fixed it - when I try to open it, I just get the beach ball and 'Not responding', without any library even installing.
  • [JavaScript Error: "Trying to update read-only document" {file: "resource://zotero/note-editor/editor.js" line: 40983}]
    Can you generate debug output from the terminal for Zotero startup through the hang and email it to support@zotero.org with a link to this thread?

  • @joycekwc: You should upgrade to Zotero 6.0.5 first and make sure it's still happening, though.
  • Thanks - I did upgrade to Zotero 6.0.5 but can't get that to open. I've followed the instructions so will send through the file with a link to this thread.
  • zotero(3)(+0000000): Backing up database 'zotero'

    zotero(4)(+0000002): PRAGMA main.locking_mode=NORMAL
    How large is your zotero.sqlite file, and how long have you waited?

    It's backing up the database — possibly to do an update, though I'm not sure why if you've been running it regularly — and may take a short while if the file is extremely large or if there's a lot of other activity on your computer.
  • @joycekwc: Or, did you open the database in an external SQLite program? Do you see multiple copies of Zotero running in Activity Monitor?
  • Or, for that matter, is something else accessing zotero.sqlite.bak, or might something be preventing Zotero from overwriting that?
Sign In or Register to comment.