Date formats are messy

The "Date" column has variety formats, such as "2013", "Dec 17", "2022 Mar 21", or even month like "July" only. I don't know when the papers were published now. Does anyone know how to resolve this issue? Thank you.
  • You can use the Year column instead.

    Fully parsed dates will be normalized to a uniform format in a future version.
  • Thank you for your reply. Though I can use the "Year" column instead, there are still many items have no year info., so the column are empty...Looking forward to the updated version that can resolve this problem.
  • What is the context where you have an item with a month but no year? I am having a hard time thinking of an example where that is the correct data.
  • I think the date format works well before. It just came messy when I imported a lot of items to update the papers in the field I focused on. There are many identical papers in my database, so I ran a java script to deduplicate the items. I have no idea if this induced the date format chaos.
  • You didn't really address bwiernik's question. The Year column is just populated from the Date field. If the item's Date value includes a year, it's shown in that column. If there's no year, there's nothing to sort by, since the column sorts chronologically.
  • Sorry I misunderstood his question. I know what you said, but I’m wondering why there are items don’t include the intact date info. As long as I have the DOI or something else to identify the items then Zotero download all the information, right? I think at least 1/3 items in my database have empty Year column.
  • Well, again, it's not really about the Year column — that's just coming from the Date field. So just look at the Date field for a specific item and see what you have.

    But this isn't something we can answer in the abstract. If you have some specific examples where you didn't get full metadata, provide URLs or DOIs (depending on whether you saved from the web or via Add Item by Identifier) and the Date value you got and we can say more.
  • I understand the Year column is extract from Date field. If Date doesn't include Year then there is nothing in Year column. I downloaded a file from Pubmed citation manager, then imported the file into Zotero. Here are some items only have months in Date field as examples: PMID: 32541866, DOI: 10.1038/s41422-020-0346-1; PMID: 33057135, DOI: 10.1038/s41422-020-00423-3; PMID: 33569317, DOI: 10.21037/tlcr-20-524. Could you check these items on your end? Thank you.
  • These items have year and month, but no day (very common for journals that publish monthly). That's correct whether you import NCBI's nbib file, save straight from Pubmed webpage, or use PMID or DOI using Add Item by Identifier. Are you sure you are not mistaking "year month" format (e.g., 2020-08, which means August 2020) for "day month"? And regardless of how they are imported, the year correctly shows in the Year column.

    Look towards the right side of the date field on the right pane. Does it not say "y m" in grey?

    If not, maybe your translators need updating? There were some misreadings of Pubmed dates, but that was a long time ago. Make sure that automatic updating of translators are checked under Zotero Preferences -> Advanced.

    (Also, why not save straight from Pubmed page within your web browser using Zotero's connectors? Much faster and easier to do than downloading citation files and importing.)
Sign In or Register to comment.