Zotero 6.0.4 correct page number in extracted annotations


I am trying to get the correct page numbers to appear in my extracted annotations in Zotero 6.0.4 (thank you to everyone who worked on the update - it is amazing!).

I have entered the correct page number range in the 'pages' field but I still get p.2 (as this is the second page of the pdf) rather than pg 64, which is the published page number.

It seems like this should be possible because the page numbers in the pictured example at https://www.zotero.org/support/pdf_reader start at p 868.

Is it a setting that I need to switch on?
  • edited March 30, 2022
    Assuming you're using the Zotero PDF reader, double-click the page number in the annotation popup or click the three-dots menu and select Edit Page Number.
  • Ahhh - I wasn't using Zotero PDF reader.

    I've just switched to Zotero's PDF reader (quit and reopened) and re-exported the annotations but no luck (see https://www.evernote.com/l/AFL-q2y5pjRMOq4oVQlC-QS6jufSXVRO5_k). Is this because my PDF is stored on OneDrive instead of Zotero's servers? Or, do the highlights/annotations have to be made in the Zotero's PDF reader for the 'Edit Page Number' to be available?
  • It’s the annotation widget in the PDF reader before you add them to a note.
  • Thank you so much @dstillman. Much appreciated.
Sign In or Register to comment.