can't use doi to add files

It continued crashing.... And I tried to add my added files again, but I couldn't do that as well. Also my web connection is good.
  • my error report: 612529921
  • What exactly do you mean by crashing?

    Make sure you're running Zotero 6.0.2, and if you're still having trouble provide a Debug ID for an attempt that fails, if you're able to.
  • It said,"Zotero could not find a record for the specified identifier. Please verify the identifier and try again."

    But doi is true... I tried several dois for several times, it still doesn't work, including what I added it before successfully.

    And yes, I used zetreo for the latest version 6.0.2.
  • D1550037387
  • edited March 24, 2022
    The Debug ID needs to show you trying to add a DOI.

    You should also post some example DOIs here.
  • 10.1016/j.irbm.2018.02.001
  • edited March 24, 2022
    The upstream service we use to retrieve metadata for many DOIs appears to be down at the moment.
  • I also have a similar problem, I can't add files with doi. Is this a common problem that many users have ?
  • edited March 24, 2022
    Yes, as I say, it's a problem with an upstream service. It will affect everyone — and many tools other than Zotero — until it's fixed, which hopefully will be within a few hours.
  • Thanks! I was thinking it was just me, especially as when I started Zotero it said it was updating.
    I'll try again later.
  • Hi everyone,

    I am also experiencing the same problem with retrieving valid doi.
    Is the issue still not fixed? Is anybody else still having this problem?

  • It's not fixed.

    There's no need for further posts on this until it's fixed — there's nothing we can do about this.
  • You can check the status of CrossRef's (the DOI provider) services here. Zotero uses the Public API and Content Negotiation.
Sign In or Register to comment.