The "Search" (Ctrl+F) function doesn't work in Reports

edited July 18, 2017
I have installed Zotero Standalone 5.0.4 and noticed that the search function is not working within Reports, produced from one or more Zotero items.
The command "Search" from the Menu "Modify" seem to produce no results.
I cannot remember whether previous versions of Zotero Standalone had a similar issue. "Search" worked perfectly in Zotero 4 for Firefox.
  • edited July 18, 2017
    Does clicking on the binocular icon work in the note? If so, make sure that you have the cursor in a note before using ctrl+f.

    Searching in notes definitely did not work -- didn't actually exist -- in Zotero 4 either for Firefox or Standalone.

    edit: so changing your question after asking it isn't terribly helpful... the question used to be about notes, note reports.
  • Click on the binoculars icon, it didn't exist in 4.0 (and searching was possible because of Firefox built-in function for Zotero reports only).
  • For reports this has never worked in Standalone, I'm afraid.
  • Uhm you've edited your original post. In reports, it has never worked. You need to save it (File > Save, or Ctrl-F) and then search in the HTML file.
  • Sorry to everyone! I meant "Reports", but typed "Notes" by mistake. The current title and initial post are now correct.

    Within a Report I see two Menus: "File" and "Modify". Under "Modify" I do find a "Search (Ctrl+F)" option, but it doesn't work.

  • That's right -- the edit (don't translate when reporting issues -- just use what you see in the language in which you use Zotero) Menu is a side-effect of the framework that Zotero uses and it doesn't work.
  • Yes it doesn't work. It's a known issue.
    Save your report, open the saved file (it will be saved as a webpage which you could open in your browser) and you'll be able to search inside it.
  • Is there any hope of having this known issue fixed? As Reports can be produced out of a great number of items, it becomes essential to have a Search function, so as to find the information one is looking for.

    Saving the Report as a file can help occasionally, but one's workflow is affected if s/he needs to produced several Reports and has to save them every time.

    I feel that this is a substantial problem (at least for me or anyone using notes for extensive transcriptions), given that the Zotero 4 for Firefox didn't have it. Basically one just used the Ctrl+F function of Firefox and would find the required keywords.

    [I use an Italian version of Zotero: thanks for the suggestion on not translating from my language into English! The "Edit" is spelled as "Modifica" in Italian]
  • I agree, but I don't think it's a top priority of the dev team (i.e. 2-3 people…). If someone with coding abilities wants to help on this issue, s/he's welcome !
    For your information:
  • Hope someone may be willing and able to help! At least in this respect Zotero 4 for Firefox is better than Zotero 5 Standalone.
  • Is there any update on this issue? I hope it may be fixed.
  • I was wondering whether this old issue might be addressed some time soon. At present, the problem occurs also on Zotero 6.
Sign In or Register to comment.