Zotero 6: zotero://open-pdf links not working

This discussion was created from comments split from: Announcing Zotero 6 and Zotero for iOS.
  • edited March 18, 2022
    Sorry to appear negative. I am really happy with Zot6 overall but I must report this issue.

    Direct links to pages in PDFs no longer seem to work in Zotero 6. These links take the following form in Zotero 6 vs. :
    Zotero6: zotero://open-pdf/library/items/items?page=9&annotation=UFT9HHI4)
    Zotero5: zotero://open-pdf/library/items/FQDRHUCLZ?page=9

    version => 6.0, platform => MacIntel, oscpu => Intel Mac OS X 10.16, locale => en-GB, appName => Zotero, appVersion => 6.0, extensions => DOI Manager (1.4.2, extension), Zotero LibreOffice Integration (5.0.25.SA.6.0, extension), Zotero Word for Mac Integration (5.0.39.SA.6.0, extension), Mdnotes for Zotero (0.1.3, extension, disabled), Folder Import for Zotero (0.0.2, extension, disabled), Better BibTex for Zotero (6.2.14, extension, disabled)

    Congratulations on this excellent release and thank you.
  • edited March 18, 2022
    Can you provide steps to reproduce this?
  • 1, Create a new item in Zotero (E.g. add DOI - 10.18637/jss.v059.i10 )
    2, Open the PDF
    3, Open the Notes pane, next to the PDF, by clicking on the notepad icon in the top-right of the window. This will show two headings 'all notes' and 'item notes'. There will be no notes for this item yet.
    4, Add a 'new item note', or 'new item note from annotations' by clicking on the plus sign.
    5, In the new note, add a citation to the bottom by clicking on the plus sign at the top of the note pane. The citation will say 'Wickham 2014'.
    6, Close the PDF and return to the library where the reference and PDF you created in step 1 is stored. Above the PDF there should be a yellow icon that have (Wickham 2014) written to the right of it.
    7, Right-click on the yellow icon and choose 'export note' from the menu that appears.
    8, In the dialog box that appears, choose 'markdown' as an export format, and ensure that the 'Include Zotero Links' checkbox is ticked. Click on OK
    9, Save the .md file and open it to see what the link looks like.
    10, This is what the link looks like in that markdown file: ([Wickham, 2014](zotero://select/library/items/items))
  • As you can see from my earlier comment, I am using the Mac version:
  • When I do that, I get this:

    ([Wickham, 2014](zotero://select/library/items/Q5TVQREI))

    @martynas_b may have some idea why you'd be getting something different.
  • Thanks. Could it be something to do with the environment/dependencies? For example Python version in the Mac? I am creating a fresh install in a VM of OS Monterey to see if it happens still. Will report back.

  • No, nothing to do with the system environment, and no reason to test in a VM. If you want to test in something, you can just test in a new Zotero profile.
  • I did as you said and created a new profile. The result was the same unfortunately.
  • Can you provide a Debug ID for reproducing this in a new profile?
  • D1119052128
  • Oh, it looks like this happens in a non-synced library.

    Is that the case in your original library as well?
  • I upgraded from Z5 and took my small library with the upgrade. I first noticed the error then. I then tried again with an empty ~/Zotero folder - same result. Then I tried with the new profile, as you suggested.
  • I am not sure about the original library. It may have been the case. Can I re-install Zotero 5 to see if this is the case? Have to use Zotfile plugin with it to achieve the export AFAIK.
  • My question was whether the library is synced with zotero.org.
  • No, it wasn't. I do have a small library up there but not one synced with my current or recent Zotero installations.
  • edited March 19, 2022
    OK, we'll fix this for the next beta and next release. Thanks for reporting.
  • How do I get around it? Should I now sync my current library with Zotero.org?
  • You can. You can also just wait a few days and it will be fixed in the next beta.
  • Excellent! Now that I have synced my library it works just fine. I also look forward to the update. Thank you!..
  • This is fixed in Zotero 6.0.1.
Sign In or Register to comment.