the build-in PDF resolver which is configured as SciHub does not work for Zotero 6.0...

previously, I configured the build-in PDF resolver as:


and It worked very well.

However, thesedays, it does not work anymore.

I don't know the causes, maybe some bugs of Zotero 6.0 or something wrong with SciHub?

Can anybody help? Thanks very much.
  • That Sci-Hub URL is no longer operational
  • I also want to know how to solve it?
  • Change the URL from to one of the Sci-Hub addresses that currently works. The “.se” address no longer works.
  • I tried this way, but it still doesn't work.
    by the way, I can download PDF from by accessing the site, but its code likely doesn't work in Zotero.
  • Can you give an example DOI
  • Of course,
    You can try to download the PDF of this one (10.1086/612649) by copying it into SCIHUB, but in Zotero, its PDF cannot be downloaded automatically.
  • @bwiernik Hi,it is confirmed that Zotero 6.0 does not support SciHub PDF resolver, but Zotero 5.0 does. Hope this bug can be fixed as soon as possible. Thanks very much.
  • @bwiernik Sorry, i found the reseason. One line of code is wrong in my plugin. It is not due to Zotero 6.0. Everything is ok with SciHub PDF resolver.
  • @iseexuhs Could you post the modification you made in your code please? Mine is identical to the first one you posted and the PDF resolver doesn't work anymore.
  • I get this error message too. After I click "ok" sci-hub opens the article, but it's not imported in Zotero.

    Captcha is required or PDF is not ready yet for "Changing adolescent dysfunctional core beliefs with group trial-based cognitive training (G-TBCT): Proposal of a preventative approach in schools".
    You will be redirected to the scihub page.
    Restart fetching process manually.
    Error message: Error: HTTP GET failed with status code 403
  • It works for me using this settings:

    { "name":"Sci-Hub", "method":"GET", "url":"{doi}", "mode":"html", "selector":"#pdf", "attribute":"src", "automatic":true }

    I had no luck using the url.

    I hope this will help.
  • edited March 24, 2022
    I forgot to mention i am using v6.0.3 with the Zotero connector v5.0.93 on Chrome v99.0.4844.82
  • @kisbalta thanks for posting your working config. For others, to use this, pick "Custom" as your resolver and type "Sci-Hub" in the Resolver field. Took me a minute to figure it out.
  • edited March 31, 2022
    @realtime99 it's been working for me now, without using @kisbalta 's configuration. However most of the times it pops up a java window that I need to click "ok" to open the sci-hub window. Does it happen to you too?
  • I still don't get this to work in 6.0.3, unfortunately.
    I tried @kisbalta 's settings and setting the resolver to "Custom" and "Sci-Hub" as @realtime99 suggested.
    The connector (v5.0.94, Firefox) still does not look for Sci-Hub it seems (but shows something like "ScienceDirect Full Text PDF").
    Any additional hints are welcome.
  • edited April 26, 2022
    @kisbalta Thanks for your idea. It's helpful for me. It can't work when using "se" but not "ru".
  • edited May 3, 2022
    @moltaire I think the error you specified is unrelated to sci-hub, Zotero can not retrieve certain Sciencedirect PDFs even if an open access pdf is available. See the topic here:
  • @moltaire “ScienceDirect” there is indicating that the PDF was downloaded from the official publisher website, either because you had access or it was open access there. That’s the excepted behavior
  • when checked the error log with configuration of @kisbalta error logs shows:

    [JavaScript Error: "ReferenceError: ZoteroPane is not defined" {file: "chrome://zotero-scihub/content/scihub.js" line: 20}]
    how can we solve it
Sign In or Register to comment.