Report id 1856272212 - Zotero and LO Integration not installing

edited January 19, 2022
I just began operating an M1 Mac Mini running Monterey 12.1 and can't get Zotero 5.0.25.SA.5.0 to integrate with LibreOffice That is, it does not even install "Installation could not be completed..." Here is the error report and output: "[JavaScript Error: "TypeError: temp is null" {file: "chrome://zotero/content/bindings/preferences-mac.xml" line: 1225}]

[JavaScript Error: "uncaught exception: unopkg at /Applications/LibreOffice failed to install"]

version =>, platform => MacIntel, oscpu => Intel Mac OS X 10.16, locale => en-US, appName => Zotero, appVersion =>, extensions => ZotFile (5.0.16, extension), Juris-M Connector (, extension), Zutilo Utility for Zotero (3.10.0, extension), ODF Scan for Zotero (2.0.43, extension), Zotero LibreOffice Integration (5.0.25.SA., extension), Zotero Word for Mac Integration (5.0.36.SA., extension)

  • I should also add that this message is returned:

    ImplementationRegistration::registerImplementation() - The service cannot be instantiated

    I had downloaded and installed JAVA JDK x64 and am not sure what else I can do tomato the integration work.
  • Your JDK should match the architecture of LibreOffice (both 32-bit or 64-bit). See
  • edited January 20, 2022
    @lisaleine: To clarify, architecture here would be Intel vs. Apple Silicon. (They're both 64-bit.) And this is probably the relevant line from the linked section:
    M1 Mac users on LibreOffice versions before 7.3 should install the x64 version of the JDK rather than the aarch64 version. LibreOffice 7.3 adds support for the ARM version of the JDK.
    So assuming you're running LibreOffice 7.1 or 7.2, you should install the Intel version of both LibreOffice and the JDK. Once 7.3 is officially released, it should be possible to run the Apple Silicon versions of LibreOffice and the JDK.

    We'll clarify this in the instructions.
  • I followed the instructions as noted by @dstillman, and it worked, it worked, it worked. Hallelujah! I installed LibreOffice and the JDK x64 version (x64 DMG Installer) for macOs provided at
    and now that JAVA version appears in the LO Preferences>Advanced field as a selected pick in the JAVA Options box, which previously had been empty. The Zotero buttons IN LibreOffice are responsive again, the picker works and brings up a box to type in and search sources in my Zotero library, and the LO Document Preferences button in for Zotero runs the selected Citations Style correctly and fully.
    Again, thank you, this is an enormously powerful tool!
  • Lastly, I should also mention that I updated Zotero to the most recent version, currently
  • @dstillman Thanks for that clarification. I couldn't get LO to recognize the Oracle JDK and spent hours looking ALL OVER the LibreOffice website (bugs, ask LibreOffice, manuals, other forums) and found no mention that LO 7.2 aarm64 simply doesn't work with JDK aarm64. Why even release LO for aarm64 then, or at least why not just put a big warning or error message that this version simply doesn't work with Java? I finally just installed the intel version of LO and JDK and it finally works. (LO x64 recognizes the JDK x64, not the aarm64 JDK that is also installed.) (smh)
Sign In or Register to comment.