Problem inserting refs in a word doc

when I try to insert a ref in the word document i get this message
“Zotero could not perform this action. Please ensure that a document is open. If you have performed a custom installation of Office, you may need to run the installer again, ensuring that “Visual Basic for Applications” is selected.”

I have passed to Mac Monterey recently and installed the latest version of microsoft office. Since then I have this problem

Please can you help ?

I have been through forum and tried many of the propositions but it does not work. Are the solutions proposed adapted to Monterey and the latest version of Microsoft office
My Word version is 16.56 (21121100) and my Zotero is

  • Have you tried restarting your computer? Did it work before on this computer before upgrade to Monterey?
  • Yes I did restart, re-install office, re-install Zotero
    I have to copy the zotero.dotm in word manually though

    Yes it did work before upgrade to Montery and buying the new office version
  • I'm sorry to say there's little we can offer in terms of support here. That error message is incorrect regarding Visual Basic for Applications (used to apply to Word 2011) but you're seeing it because there's a fundamental communication issue in the Word API on your machine. That is likely due to some issue with AppleScript/Apple Events in macOS or in the Word installation. It's possible something went wrong during the Monterey update and it's likely that reinstalling the OS would help here.
  • Thank you very much anyway, I'll try to reinstall the OS
Sign In or Register to comment.