Please Help: Zotero Sync Not Preserving Folder Structures after Mendeley Import

edited October 28, 2021

I'm having problems with the Zotero sync after Mendeley import.

I had attempted a Mendeley import a month ago, but aborted this halfway through.
To do a fresh import yesterday, I purged Zotero Web data and deleted all the entries remaining in the Zotero Web Library manually, including the folder structures from my previous import (which I now see was probably the cause of the problem..?). I also unchecked the automatic Zotero sync on the desktop while the new Mendeley import was ongoing.

I've successfully imported Mendeley library to my Zotero desktop, but when I synced my data to Zotero web afterwards by pressing the sync button, the folder structure disappeared.
So right now my Web library is a large lump of unorganized entries, sorted only by tags. All folder were imported fine into the Zotero desktop during the Mendeley import, but the Zotero sync has somehow turned out to be a disaster.

Is there any way to revive the folder structures? Or should I redo Mendeley import again? I'm not sure if redoing the Mendeley import will return the folder structures, and I'm afraid of making duplicates.

(Error Report: 1502535020)
  • Restart Zotero and try the import again. Don't delete anything. You shouldn't get duplicates as long as you've only used the official importer.
  • edited October 29, 2021
    Okay, I was trying to rename my pdfs just before, and I must have clicked on something accidentally (although I'm not sure I touched anything). Right now I've restarted Zotero, and somehow all of my Pdf files are stashed under one random parent entry.

    Should I try to delete my Zotero data and redo the import? I'm not sure what will happen if I try the import at this stage without deleting the chaotic library.

  • somehow all of my Pdf files are stashed under one random parent entry
    It sounds like you dragged all the selected PDFs onto an item by mistake.

    Are you seeing that in your online library? If not, you should just close Zotero, delete zotero.sqlite, reopen Zotero, and sync to pull down your data from the online library.
  • edited October 29, 2021
    This was on my Zotero desktop, so I will do the sync and if all goes well, I'll retry the import, too. Thank you so much so far!
  • This was on my Zotero desktop
    Right, I'm asking if you're seeing the same thing in your online library — i.e., if that erroneous change has already synced to your online library, in which case there's no point in deleting the database and syncing down the online library, since it will be the same.

    For the files, you're just deleting the database. It has no effect on the files.
  • edited October 29, 2021
    The sync worked fine, but the Mendeley import stopped halfway with this message:
    "An error occurred while trying to import the selected file. Please ensure that the file is valid and try again." (Error Report: 2060467152)

    While I do have the folder structures back, there are duplicates of each folder. (Not duplicates of the entries, just the folders) Also, not all the entries have been sorted into their original folder locations, so that some folders are half- or entirely empty.

  • edited October 29, 2021
    Can you provide a Debug ID (different from a Report ID) for an import attempt that fails?

    Don't worry about duplicates for now — if there are any once the import goes through successfully, we'll debug that separately.
  • Here is the Debug ID: D430059101
  • edited October 30, 2021
    Did the import stop with an error while you were logging that?
  • edited October 30, 2021
    Yes, it did. The error report ID was 39208620 -- forgot to mention that!
  • edited October 30, 2021
    Can you provide another Debug ID for Zotero startup through the import error, using the "Restart with Logging Enabled" option? (We don't need a separate Report ID.)
  • D502963580, I repeated the import process.
  • edited October 30, 2021
    Sorry, but that just shows lots of full-text indexing, which happens automatically in the background on idle. We really need the report submitted as soon as the error appears. (I know that may be difficult if the import takes a while, but otherwise lots of additional output pushes the relevant lines out of the log.)
  • edited October 30, 2021
    @wtlerin: Also, if you go to Tools → Developer → Run JavaScript and run this line, what's the output?


  • edited October 31, 2021
    D2015686. I tried to submit the Debug output as fast as I could after the error.

    Yes, the output for that line is "report."
  • OK, thanks — we'll investigate.
  • Hello,
    I recently retried the import, but it stopped with an error exactly as it did a month ago. There seems to be a particular file that's making trouble.

    Can you look into this? I did another debug logging for the process: D356685900
Sign In or Register to comment.