Trouble Using Firefox Plug-in to View PDFs in Browser Window


Not sure if this has been discussed before, but while in the past I could open PDFs in my browser window from Zotero with no problem, now I'm being prompted to select which application to use to open that file - and the Adobe PDF plug-in for Firefox isn't one of the available options, so that I can only choose (in my case) PDF X-Change viewer, which opens outside the browser. Does anyone know how I set things back to the way they were? I'm not actually sure why the settings changed in the first place - I didn't do anything to cause this, in so far as I'm aware ....

  • I have the same problem! Help!
  • panopticon - I FINALLY GOT IT TO WORK... but I am not necessarily sure that I know how it happened in the end. Try disabling the plugin for Adobe Reader in Firefox. This will allow you to choose the plugin for Foxit for Mozilla in the Tools>Applications menu of Firefox. This was previously not an option.

    Then, make sure that your about.config "lauchnonnativefiles" is set to "false" (which is the default, but I had changed it while trying to fix the problem). See:

    Good luck!
  • I had a similar problem (PDFs stored in my Zotero library would not open in Firefox/would only open in Acrobat or Preview) and here is what finally worked to fix it. As far as I can tell, the issue had to do with my Firefox preference settings. Even though I had the PDF plug-in for Firefox, I could not change my preferences to use it as default. It turned out that I still had some files from older versions of Firefox in my profile folder, so I deleted those as well as every file that could safely be deleted and that fixed it. You can find a list of files in the profile folder and descriptions of their functions here:
  • edited October 12, 2009
    Deleting mimeTypes.rdf, which stores file handling settings, from the Firefox profile is generally what's needed to fix file opening weirdness. All Zotero does it check if a file can be handled within Firefox (natively or via a plugin) and then either sends it to Firefox if so or otherwise launches it via the OS. But problems in mimeTypes.rdf can prevent this from working properly.
  • So is mimeTypes.rdf a Firefox file or a Zotero file? If it is a Firefox file, is it not needed for Firefox to work properly with other websites and files?
  • mimetypes.rdf is part of your firefox profile (nothing inherently to do with Zotero). Firefox will recreate a default one if it is deleted.
  • On Mac OS (Leopard) systems, try the Firefox PDF Plugin for Mac OS, which makes use of the Mac's native PDF handling abilities. Works very nicely for me.
  • Bryan: Yes, but this thread is about cases where file opening isn't working as expected with a plugin installed.
  • Whenever I open a PDF (whether through Zotero or otherwise), Firefox will open an infinite number of tabs, not stopping. Please help.
  • uninstall your pdf plugin as a start.
  • that didn't work, but have used a work around -- setting by default PDF application to Nitro or Adobe
  • I had this issue until recently, but actually liked it. (It seems to have gone away with this recent update of Zotero). Opening pdf files in a new window (in Adobe Reader) made them considerably easier to read, especially in my small-screen netbook portable computer.
    I would like to suggest adding this feature to Zotero: a choice as to whether pdf's called through Zotero should open in Firefox or in their associated application.
  • I would like to suggest adding this feature to Zotero: a choice as to whether pdf's called through Zotero should open in Firefox or in their associated application.
    It already exists. Enable the launchNonNativeFiles hidden pref.
  • Excellent. Thank you.
Sign In or Register to comment.