Zotero not using the default Ubuntu browser

edited October 22, 2021
When I double click on an item in Zotero, it opens the URL in Chrome.
If I go to Settings -> Default Applications, I have

.. Web -> Firefox Web Browser
.. Mail -> Google Chrome
.. ...

So I expect Zotero to open items in Firefox (as I want).
Why is this not happening? How can I change this?
Note: I ruled out the possibility that Zotero is using the setting for Mail. I changed it to mutt (Firefox is not an option), and items are still opened in Chrome.
Sign In or Register to comment.