Database Corrupted. sqlite file too big for repair tool.

I keep getting the error message that my database is corrupted and that it will load from the most recent automatic backup. But It keeps crashing and restarting this process every time I try to use it. I am guessing either the backup is corrupted too or it isn't actually loading???

The file is stored in the proper place on my mac - User > Zotero but I was having issues with my new mac & Big Sur (pink screen o' death) so I am sure the constant crashing probably caused the corruption.

I have searched the forum and tried to use the repair tool but my sqlite file is way too big (1.11 gb).

I also tried to check the Database Integrity using the advanced function in preferences but when I click the button nothing happens. The program just freezes and/or crashes.

I backed up the entire folder to an external drive just in case but if both the sqlite & sqlite.bak files are damaged I am (again) guessing that deleting & reloading them to my computer's hard drive won't do anything??

Any ideas? THX.
Sign In or Register to comment.