reorganizing citations

edited August 13, 2021
I am using the most current versions of both Zotero an LibreOffice, on macOS BigSur. The same mess happens when I either reorganize text (shifting paragraphs, etc) which contains a zotero reference, such as to change the order of the reference numbering OR hit "Refresh". The following prompt appears:

"You have modified this citation since Zotero generated it. Do you want to keep your modifications and prevent future updates?
Clicking Yes will prevent Zotero from updating this citation if you add additional citations, switch styles, or modify the item to which it refers. Clicking No will erase your changes.
Original: 10
Modified: 10107"

This is a confusing and ambiguous choice. If I click "No", then Zotero runs through my four-page document and repeatedly adds the same reference number, e.g. 3333333 or 10101010 etc. etc. The same thing happens if I hit the "refresh" button. Eventually, LibreOffice has enough, and crashes. Zotero may also crash.

Please, I only want to reorder a lit. reference order or enter a new one into the middle of the text.
If you need to move this question some place else, then please do so,
  • If you go into Zotero Document Preferences are you using ReferenceMarks or Bookmarks to store citations? If it is Bookmarks, you should switch to ReferenceMarks, because Bookmarks are prone to exactly the type of corruption you are describing. If it is ReferenceMarks see debugging broken documents.
  • edited August 13, 2021
    I tried the following, below. Initially it worked. But then the same old crap returned.

    a. "ReferenceMarks" was already correctly chosen. So I then went to the 'debugging' site.
    b. In a blank document, "Track changes" was already turned on. I created four text entries (test 2-1, test 2-2, test 2-3, test-4) and then four dummy references.. The corresponding bibliography was produced correctly.
    c. After deactivating "track changes" in the new file, I re-ordered the text entries (test 2-1, test 2-4, test 2-3, test-2) and hit "refresh". The bibliography was then correctly re-sorted.
    d. I created a duplicate file, which included the original Zotero references.
    "Track changes" had already been activated in the duplicate file, but deactivating it produced no changes.
    e. In the _duplicate_, but not the original, activating "accept all changes" cleaned up the duplicate references.

    Thanks for your help,

  • edited August 13, 2021
    This is awful. It won't even let me "unlink" the citations so that I can start all over again.
    3333 3 3 33 3333333333 3 3 33 33333333333333
    I've wasted my morning.
  • Neither can I erase the library to start over again. The same old nonsense message comes back, and Zotero just keeps up with its numerical nonsense. It was finally necessary to do a force quit it stop it.
  • Don't erase the library.

    The Troubleshooting Errors in Word Processor Documents steps explain how to isolate pretty much any problem so that you can either fix it yourself or email us a document excerpt to look at. You'll need to follow those steps to the end.
Sign In or Register to comment.