Attachments not syncing [resolved]

edited May 19, 2021

at the moment in time, PDF attachments in our group 2405685 don't seem to sync. We've tried from several Zotero clients - the sync seems to be normal. But on other clients, only the entry for the attachment appears. When you try to download the attachment, we get a "file not found / not syncd" error.

Just wondering what might cause that?

(PS: E.g. items IRSI6S5B and I5IDVHIQ.)
  • For the file failing to upload, I see this in the logs:
    (3)(+0000001): Initializing download request 4/I5IDVHIQ
    (3)(+0000000): Starting download request 4/I5IDVHIQ
    (3)(+0000000): Saving
    (2)(+0000001): progressMax has changed from 0 to 9 for request '4/I5IDVHIQ'
    (3)(+0000000): Setting image download percentage to 100 for item 4/I5IDVHIQ
    (3)(+0000001): Remote file not found for item 4/I5IDVHIQ
    (3)(+0000003): Download request 4/I5IDVHIQ finished
    (3)(+0000000): Setting image download percentage to false for item 4/I5IDVHIQ
    Debug: D1434166212

    For the file failing to fetch (which is not uploading the other end): D1490908785

  • edited May 18, 2021
    (3)(+0000001): 2 files to download for EdTech Hub Evidence Library

    (3)(+0000004): No files to upload for EdTech Hub Evidence Library
    That file is queued for downloading, not uploading. It doesn't appear to have changed locally (or doesn't exist on the computer where you generated that debug output — I can't tell from the output).
  • edited May 18, 2021
    Yes, sorry - one file was for downloading, the other for uploading. Basically, a colleague and I added a file attachment to an item, but only the attachment metadata came through, the file itself never became available (i.e., the 'doesn't exist'), despite my colleague manually syncing several times. I'll do some more tests tomorrow.
  • edited May 19, 2021
    No, I'm saying neither is for uploading. The above output "No files to upload" is from the one you said was failing to upload. There's no indication that there's a local file with a newer timestamp, which would be queued for uploading.
  • Ah yes! So our workflow yesterday was:

    (1) Add attachment to Zotero item
    (2) Wait for it to upload.
    (3) Sync another Zotero (different user)
    (4) Result: File not available. (Neither for the other user, not API).

    We tried this several times (over a space of a few hours), for different items / files, etc (from several different users), and got the same issues. However, today the same workflow works again. So must have been a temporary issue!

Sign In or Register to comment.