edited May 18, 2021
I am working on a bog document with 350 pages in Word (16.48) on a Mac.
Due to the documents size, I have disabled automatic updating to manually refresh the document every now and then.
Now for some reason, the main part of my many citations is underlined which I understand as Zotero telling me that these ones are not updated yet.

Once I "refresh", my document closes all of a sudden and Zotero opens automatically with nothing happening. It doesn't seem to refresh but also doesn't show any errors.
Does anyone know what to do?

And: How would I know that Zotero works on the refreshing?
  • A Debug ID from Zotero for such a failing refresh might help us figure out what's happening. However you should know that unfortunately the Word for Mac integration struggles with documents of such size and if you have opportunity to switch to a Windows computer to work on this document it will likely resolve all your issues. Even running a VM with Windows on your Mac is likely to be faster. Otherwise, you should follow the debugging broken documents instructions, they might help you fix the document.

    What Mac are you working on?
  • MacBook Pro 2017 with Catalina 10.15.7.

    I don't see a chance to change to a windows computer by bow unfortunately...

    I tried to produce the problem once over: D1973795513

    Does that help anything?

    I will try the debugging broken documents now, maybe that will change something as well...
  • I tried all the debugging things, nothing seems to help.
  • I tried it with a two pages sample of the document - that worked well. How could I proceed now with the huge document without causing any errors? Splitting it up in smaller ones, refreshing those and then putting them back together?
  • I am near to throwing my thesis out of the window...

    The split up documents worked alright when it comes to refreshing, but somehow the entire formatting of the document itself changed so that no help whatsoever...
  • Did you see the suggestion on using a Windows machine for the refresh? That'd likely be the easiest.
    I can't look at the debug, so someone else would see if there's something in there. I'd have expected this to simply take an extraordinarily long time (i.e. easily several hours) on Mac.
  • @Ricardaseifert: It looks like you pressed Refresh a second time after a few seconds, and then submitted that output a few seconds later. Again, this could easily take hours. You should try just letting it go for a while. You can open the debug output window via Help → Debug Output Logging → View Output to see if anything is happening, though there may be pauses without any activity.
Sign In or Register to comment.