How to change comma to colon in auther date

Hello, I would like to change the format of how in text citaions are handled from -

(Attali, 1985, p.134) to (Attali 1985: 134)

So removing comm's and inserting a colon, Is there a way I can do this, is it set in preferneces?

Many thanks in advance.
  • You will need to modify the citation style.
    General instructions on how to are here:

    What style are you using? Then we can actually give some specific instructions.
  • Thanks for the swift reply, I am using,
    Chicago Manual of Style 17th (author-date)
    English UK
  • edited April 20, 2020
    It is set by the group delimiter in line 600. Change that to what you want.
    Make sure to follow the above-linked guy and change ID and self link and file name, otherwise the style will be overwritten.
  • Thanks, yes I jut notied I change it from Harvard, I will give it a go. Looks complicated, is there not a template already in zotero?
  • There is 1034 unique author-date styles on the repository you can pick from:

  • Found it in the library, if any others need this format:

    Cambridge MHRA
  • edited March 25, 2021
    Greetings. I've used the general instructions and modified the CMS author-date style. I changed the group delimiter in the in-text citation from comma to colon... and I've added a space after the colon for there to be a separation between the colon and the page number. I also changed the way to refer to contributors: shortened versions of "ed." and "trans.". With much hassle and aleatory attempts, I managed to download the style, but when inserted the modified style in my document through "document preferences" two things happened:

    1. There is no space between the colon and the page number in the in-text citations.
    2. The label of the contributors didn't change to the shortened versions. The verb form remained for referring to contributors in the reference list.

    Any ideas as to how to fix this? Thanks!!
Sign In or Register to comment.