colored tag option doesn't appear

I keep having problems with creating colored tags. The tags are there, but I cannot assign a color. I have only used 5 colors.
  • Where exactly does this fail? What options do you get when you right-click on a tag in the tag selector?
  • Are you using the web library or the Zotero desktop app? You can only assign new tag colors in the desktop app.
  • I have the same problem, I cannot assign a color.
    When I right-click on a tag in the desktop app, nothing happens. If I see correctly from the docs [1], a menu with coloring options (among others) should appear.
    Perhaps I'm missing something? :)

    Zotero desktop app version: 5.0.94
    OS: macOS Catalina

  • I now found the source of the confusion.
    The tags _cannot_ be right-clicked in info column on the right, where one can also easily add tags. Assigning colors only works for me if I right-click tags in the small window in the left lower corner (I suspect this is the tag selector, contrary to the other tag editing place, so I got them mixed up).

    Is it intentional that right-clicking doesn't work in the column on the right?
  • Yes, it's intentional. The tags in the right-hand pane are tags on the item, so assigning a global color to them there doesn't really make sense. You assign colors in the tag selector, which is the global view of the tags. Same with deleting globally, which also isn't an option from the item pane.
  • hey I am using my Mac2020 (M1) and for my version of Zotero, when I clicked right on the tags in the tag section on the bottom left section, nothing showed up...actually the cursor just turned into a hand and the only option is to click it and there showed the documents with that tag. Am I the only one..? does someone know how to sort it out? greatly appreciated!!
  • edited February 12, 2021
    @Michelle0130: To be clear, you have to right-click (or control-click) on the tags to get the menu. It works like any other context menu. If you left-click it will just filter to that tag.
Sign In or Register to comment.