Very sluggish graphical performance in Zotero on 144Hz main monitor

edited September 16, 2020
As the only software on my computer, Zotero is having performance issues. All actions are completed immediately, indexing and search seems fine, but the "graphical" performance is out of this world. Whenever I drag my mouse over to Zotero, it feels like my screen is running at 25fps/25Hz (maybe 60fps/60Hz), while all other programs run smoothly at 144Hz.

However, if I drag the software over to my secondary monitor (60Hz), it feels OK to use again. Is this a known issue? I saw a thread about this earlier, but I didn't really understand if a solution was posted.
  • We haven't tested Zotero on a monitor like that. You'd want to research any problems reported with Firefox 60 (on which Zotero is currently based) on such a monitor and whether there was anything that could be adjusted in about:config to make it work better.

    (We'll be upgrading to a Firefox 78 base in the not-too-distant future.)
  • edited December 2, 2020
    I had the same problem, disabling hardware acceleration fixes the issue:
    * File -> Preferences
    * General tab -> Config Editor
    * Accept warning
    * Search for "layers.acceleration.disabled" and set to true
    * Restart Zotero

    Edit: The previous setting (media.hardware-video-decoding.enabled) was the wrong one.
  • @enricoseiler: Are you sure it was that one? Can you reproduce by toggling back? That pref should only apply to video decoding, which doesn’t happen in Zotero.
  • edited December 2, 2020
    @dstillman you are right. I couldn't reproduce it and I have no idea why it worked for me... However, I found that "layers.acceleration.disabled" is the correct setting and I can reproduce the problem by toggling this pref. I edited my previous message accordingly.
Sign In or Register to comment.