"sync server did not accept your username and password."

*sync problem*
Under 'preferences'->'settings' the username and password are set, and these are the same ones with which I do my login for the Zotero website.
But when I try to sync, I get the error message: "The Zotero sync server did not accept your username and password." This then refers me back to the preferences menu.
What am I doing wrong? A bit of advice would be really appreciated.

Both standalone and zotero for firefox installed.
  • edited May 25, 2015
    We're not aware of any causes of this other than genuinely incorrect login info. It's vaguely possible that a character in your password could cause a problem, but we're not aware of any current issues with that.

    I'd suggest clearing your username and password completely in the dialog and reentering.
  • Thank you for your tip. It was indeed as you said: "a character in the password".
    I don't know if it's documented anywhere: the zotero *website* accepts special characters in the pw (in this case: a '$'), but the sync server does not. (Though the error message should have been more specific: it should have said: 'invalid character in password'.) Needs fixing, I guess.
    Thanks again.
    Dr. Frederik van Gelder
  • I believe there's a bug here — we've had occasional reports of similar issues in the past — but it's not that straightforward. I can create a password with a '$' (and lots of other non-alphanumeric characters) and sync with it, and I'd guess that if you reset your password, you could too. If you can figure out how to reproduce this easily, let us know.

    In any case, Zotero 5.0 will feature a completely rewritten syncing architecture, so whatever the issue is here, it will likely go away with that.
  • I'm too relieved now that it's working again to want to play around with that password, but the one that produced the error code - untill I removed the '$' - was this:

    Hope that helps.
  • This solution did not work for me. *sigh*. I would really appreciate any help. I've tried password changes of varying lengths and complexities, rebooting Zotero, full computer reboot, erase and reenter username and password, enter password by cut-and-paste and enter password manually. Any more ideas?
  • have you tried restricting the password to just number and letters, at least for testing?
  • Yes, I have tried that. I've also reduced the password to only 10 characters without success.
  • jpiaskowski: Try your username instead of your email address. (Either should work, and I'm not sure why it's not, but I imagine that will fix it if you're using the correct password.)
  • I have to admit that my own 'eureka'-cry of a few weeks ago was premature. It *did* happen again, with our without special characters in that password. But *this* time simply doing the 'request-new-password' routine did it. (My current pw is 16 charac. long.)
  • I have tried that several times without success, by itself and also by first deleting my name and password, closing, reopening and re-entering my information into Zotero.
  • Issue solved with (1) my username (not my email) and (2) a password using letters only (no numbers or symbols). Thank you for your help.
  • You definitely don't need to use a password with letters only. As I said above, I think there's some sort of caching bug here that a few users are hitting. I don't think it's about the specific password.
  • edited June 11, 2015
    The problem started when I switched to using a password manager for my logins. I started with a typical secure password and gradually simplified it until something got in. I did check repeatedly to ensure that I was actually entering the correct password - an easy thing to miss with a complex password. My check was that I could got into the website via a manual login (i.e. typing by hand) while I could not sync the libraries on my standalone version of the software. I will try amping up the security of the password and see if that changes anything.
  • What is the ETA for Zotero 5.0?
  • I just ran into this problem again syncing with newly installed version of Zotero on a different computer. What did work is when I used Tools > Preferences for entering my username and password. This is in contrast to clicking the circular green arrow on the upper right, seeing the red exclaimation point of failure to sync and then clicking "Open Sync Preferences." It may be coincidental that the standalone Zotero accepted my password at that moment, but that was the only apparent change in my attempts to sync my libraries.
  • Hey,
    I've got the same problem but have an additional piece of information that (maybe) could help find the bug. I had the zotero standalone installed on my computer (C:\...), my zotero profile was located in C:\users\... and everything worked fine. Now, the tech-guy re-installed the standalone so that all users on the computer can have access to it, and he moved my zotero profile to a local server. When I use the program, all my references are there, but the sync won't work anymore because I get that error saying the sync server rejected my password.

    Hope this helps!
  • I have had a lot of trouble with the same issue: "sync server did not accept your username and password". It happens on a couple of different computers (though not always) and I am running Firefox 38.0.5 and Zotero

    I've also experienced this strange hiccup with WebDav syncing and can't make logical sense of it. I use Box Sync which requires one to set up an external account and password to use WebDav (versus just using Box through my university account and password). I had it working fine all semester, although it took a lot of conversations with Box people (and a few with zotero folks I believe).

    Box requires one cap. and one symbol in the external password (the one relevant for the WebDav). What is very strange is that I got a new computer and set everything up from scratch and have only been able to get the WebDav part of the sync function to work intermittently (the general library sync for zotero sources works fine). I've changed the password several times, rebooted firefox, restarted the computer, etc. at various times.

    I finally got it working on my laptop (not clear how) and now I'm trying to get my desktop work computer to sync with Box using the WebDav and it keeps reporting what people here get: "sync server did not accept your username and password". This is really bizarre because I am running the same versions of both Zotero and Firefox on both computers and have them sitting next to each other. One works and one doesn't (and I've very meticulously typed in the same passwords, name, etc.). At first I thought that having a master password for the general Firefox sync and password memory might confuse the WebDav, but that doesn't seem to be the case for the one that it is working on.

    I figured I would just add my info. from the same scenario to the thread in case it helped solve this problem. I did have two questions:

    1. What is the difference between "download files" "as needed" and "download files" "at sync time"
    2. Do you anticipate most file syncing with 3rd parties to be cleared up with Zotero 5?

    Thanks so much! I love Zotero and all the hard work you guys put in. Just trying to do my part to help make it better.

    All best,

    Dr. Jonathan K
  • Are you saying you get the "The WebDav server did not accept..." message when you try to verify the server? Because otherwise, the problem is the Zotero password, not the WebDAV one.

    To your questions:
    1. At sync time: always download all files from the server to the local machine.
    As needed: only download files from the server as you try to open them on the local machine.
    (For both settings, files are always uploaded)

    2. There are no known issues syncing with well-specified 3rd party webDAV servers and there are no changes I'm aware of to how that sync will work in Zotero 5. Almost all of the issue with webDAV sync that are reported here are problems in the webDAV specification by the provider and there's not much the new Zotero version could do to fix those.
  • (But Jonathan, if you are having WebDAV issues, please start a new thread. This one isn't about WebDAV at all.)
  • right, sorry for going off topic, but it does sound like it actually _is_ the same problem. The sync error for a wrong webDAV password says "WebDAV verification failed," not the "Sync server did not accept... error he's getting.
  • Dear Dan and Adam,

    I'm sorry if I went off topic. To be honest I can't remember if the error said "WebDav" or "Sync server" but it definitely said "did not accept your username and password". I can't actually verify which message because it is actually working now! I know this probably seems a bit frustrating and I hope I didn't waste your time.

    My guess is that with the complexities of third party WebDavs it might take a little while (for me it seems like at least 1/2 an hour with Box) before the WebDav recognizes the new password. Hopefully that can help you guys advise others on that particular issue so I didn't totally muck it up. I do try to troubleshoot on my own for awhile before posting.

    All best,

  • DebugID D292509473

    I am having the same issue as fvg with sync

    I have tried several times to change my password both on the Zotero website and on the Zotero frame.
    Under 'preferences'->'settings' the username and password are set, and these are the same ones with which I do my login for the Zotero website.
    But when I try to sync, I get the error message: "The Zotero sync server did not accept your username and password." This then refers me back to the preferences menu.

    Can anyone help me fixing this problem?
  • Dear All,

    I have the same problem that bichette has, and have tried changing the password similiarly. The only additional information is that I have a new laptop and have downloaded the Standalone very recently.

    Please help.
  • bichette/rosan.w.chow: What I say above still applies:
    We're not aware of any causes of this other than genuinely incorrect login info. It's vaguely possible that a character in your password could cause a problem, but we're not aware of any current issues with that.

    I'd suggest clearing your username and password completely in the dialog and reentering.
  • The same problem here :(

    My server requires changing the password each 6 months.
    Generic combination of 16 letters/digits, I changed the last digit only. With a new password everything works - thunderbird, webmail, ownlcoud, even zotero in windows in virtualbox on the same PC. Just changing the last digit in saved passwords. But not zotero/firefox on linux. Have tried everything - cleaning/reentering etc. One can see the username/password in firefox settings as a saved password - these are correct. However, zotero keeps refusing it saying that webdav does not accept your username / password.

    Just to point that this is not a problem with a wrong character or webdav problem. There is some bug in zotero and I recall having similar problem last time - 6 months ago - but that disappeared before I started digging into it.
  • Couple of hours later - it suddenly started working. Without anything being changed at all. Just done some other work, launched Firefox and saw that Zotero started syncing.
  • I had the same issue when I entered my credentials through the synch dialog (clicking on red exclamation mark) on a new install on Windows 10. When I entered the exact same through Tools\Preferences, synch worked immediately.
  • I ran into this same problem, using Zotero 5.0.23 on Linux, and found a different solution. On the Linux version at least, the dialog box initially shows a field for the user name, a field for the password, and a "Set Up Syncing" button, which is disabled.

    If I type in my username, and then paste in my password (using Unix middle-click select-and-paste, if that matters), the "Set Up Syncing" button remains disabled. So I clicked "Close", resulting (presumably) in the settings not being saved, and sync failing.

    When I type in the password by hand, "Set Up Syncing" becomes enabled, I click it, the dialog box lights up with lots of other stuff, and syncing works fine.

    Incidentally, if I then unlink the account, I get back to the initial dialog box, but now the "Set Up Syncing" button is enabled, even without anything filled in.

    I'm not sure if this is the problem others are having, but I figured I'd throw it out here in case it helps someone.
  • This bug was related to pasting (versus typing) the password and has been fixed in Zotero 5.0.24.
  • I don't think it has been fixed, since I experienced it with the latest 5.0.93 version. Copying the password gave the error, typing it manually or selecting it from a text file and dragging it worked.
Sign In or Register to comment.