Problems trying to Edit Citation using the Word Plugin

Zotero edit citation Word's plugin button works perfectly until I save my file.
After the fiel is save all citations inserted before the last save become "uneditable" and the when I try to edit (having the cursor over the citation as previously worked) plugin gives the followin message : "The cursor is not present within a zotero citation. bla bla bla ..."
The issue just happens when the document is saved, all citations inserted after a save are editable till the next save when they join the old ones on an "uneditable" stated.

Thanks in advance
  • my guess would be that you are saving in the wrong format.
    If you are using "fields" in Open Office and save as a .doc file this is what happens.
  • Hi Adam, thanks for your replay but I'm using Word 2007.

    I did some additional tests.
    My problem was not occurring just because I was saving the file but, I suppose, due to the fact that my citations where include inside a table (in the second column of a 4 columns several rows table).
    I did some additional tests and looks like that only the last citation (from top-down) per column (I tested using citations in several columns) becomes editable and does not bring me the error. Does not matter insertion order, what seems to matter is that the last citation per column (from top-down) continues to be editable and the other get the error when I click the edit button.

    seems to be a general problem. I thought this was only in Ooo.
    Dan - do you have any input on this - it's coming up a lot.
  • Editing citations in tables works fine for me in Word 2003. ewandro, are you using fields or bookmarks?
  • Hi Dan,

    I'm using fields with WOrd 2007. I tried with 2007 docx and 2003 doc format and I have the same problem with both.
Sign In or Register to comment.