Zotero opens wrong position/size

I cannot get Zotero to open where/the size I want and it's bugging me.

Whatever I do I cannot get rid of a small gap to the left and bottom. I can resize it each time but when it reopens, there's the gap. I've tried the recommended Windows 10 solutions (CTRL-click on Close; SHIFT-click on close) and I've tried utilities but Zotero ignores them all!

Ideas please? Is there a setting I'm missing?

  • Can you take a screenshot of what you're describing, upload it somewhere (e.g., Dropbox), and provide a link here? I'm not understanding what you mean here.
  • I'm not sure what that's supposed to be showing. Nothing looks wrong there.
  • Perhaps I should expand: when I resize the Zotero window, Windows 10 remembers the top and right side positions, but not the left and bottom. I can resize it to the left side and bottom, but Zotero won't reopen to those positions - it always leaves a little gap.
    This hasn't always been the case, and I have started having a similar problem with PaintShopPro 2019. No doubt it's a Windows problem but I haven't been able to cure it with Zotero, although other apps seem OK.
  • I know it's only a few pixels but there's a gap to the left and between the Zotero window and the taskbar.
  • edited November 6, 2020
    I can reproduce that, but I'm pretty sure that's from Mozilla/Firefox windowing code that we inherit and not something we can easily fix. (It happens with other windows too, like the Advanced Search window.) It might go away automatically in a future version when we upgrade the Mozilla platform we're based on.

    For what it's worth, this only happens if you resize manually. If you just maximize the window, it doesn't appear to happen.
  • Thanks. It's no big deal but of course it's nice to know it's not me!
Sign In or Register to comment.