Zotero local will not start up

Zotero on my MacBook Pro w/ OSX 10.14.6 will no longer start up, instead endlessly showing the start-up bar. I let it try for 24 hours, nothing, so have to force quit. I am successfully using my Online Zotero library, and that seems intact. What can I do to get Z to startup on my local machine? I tried deleting my prefs and User Profile but that would not work ... any advice on problematic start-up solutions would be nice!
  • Unless you have a very large library, there's no need to wait more than a few seconds to know that something's wrong.

    Is your Zotero data directory in the default location?

    See Reporting Startup Errors. We'd want the Debug ID from that if possible.
  • Zotero V 5.0.90

    I had a custom location for the data directory, not the default. The library *is* large.

    Not possible to access the 'Help" menu.
  • Is the custom location in a cloud storage folder?
    Not possible to access the 'Help" menu.
    You don't need to do that for the instructions I provided.
  • Not in the Cloud, per se, but on a remote server that I am VPN'ed into. However that db location is at least a year old, don't know why that is in the prefs -- I had transferred the library to my local laptop last year because of the constant synching issues. After that move, things worked okay, though the synching issues still dogged the use of Zotero. Then, at some point in the last few months, Zotero got into this start-up problem, so, since then, I've been using only the Web library, and gave up on local use which is quite problematic.

    The library *is* very large.

    (I ran the debug process, but that hung up. I made a screen shot that I can't post here with the info). I'll follow up with more information tomorrow...
  • You can upload screenshots to Dropbox or similar and provide a link here.

    But you'll want to make sure Zotero is startup up from a data directory on your local disk.
  • Here's the link to the debug log https://mines0-my.sharepoint.com/:i:/g/personal/jchopkins_mines_edu/ETuof0KwE6BGpJoW50Z-OUUBvalZ4HlDZC3fI9tuKRhqqg?e=Wr9uB2

    I said in my note: "I updated the thread, and attach a screenshot of the debug report, which is still "Backing up database 'zotero'" -- I will let this process go on an hour and then kill it ... the database directory location is not correct, it's one that hasn't been used for a couple years, it should be on my local machine... So, I killed the network connection to that remote server and that killed the debug process... How/where can I change the db location string to the local db? "

    Sry if this is cryptic, I'll try to follow up with anything more that I can think of!
  • If you can't get to the preferences, you can go to your Zotero profile directory, open prefs.js in a text editor, and reset the extensions.zotero.dataDir and extensions.zotero.useDataDir lines to have it revert to the default location ("Zotero" in your home directory).
  • I have done that, but now, how to safely re-sync the local database with our online zotero.org database -- without risk of damaging the online db? We can't take the risk of something happening to our definitive library!
  • edited September 22, 2020
    Zotero only syncs explicit changes and deletions. Unless you've made changes elsewhere that you want to overwrite, all you need to do is sync.

    Obviously you should make sure you have a complete backup of your Zotero data directory at all times.
  • However, that's the main problem -- that my original local directory got corrupted or such, so, resetting the local situation as per your instructions means that it is an empty db. That would seem to be an 'explicit change' that could tell the zotero.org account to erase the entire online library when I try to sync. And that is what I, of course, can't let happen. Is there no way to tell Zotero when starting a sync process in this situation to ignore the local db state, and favor the remote db?

    Or is there a way to simply download the intact online db directly, then re-connect it as the new local db?
  • edited September 23, 2020
    A new, empty database isn't an explicit change — it's just an new database, as if you were using a new computer. Obviously if you sync a new computer, Zotero doesn't wipe out your online library.

    An explicit change would be deleting all the items in your library within Zotero.
    Is there no way to tell Zotero when starting a sync process in this situation to ignore the local db state, and favor the remote db?
    There is, in the Sync prefs, but you don't need it here, and you shouldn't use it unnecessarily.
  • @cgsadmin: To be clear, though, while syncing a new database wouldn't affect your online library, it's not what I said to do. I just said how to reset the data directory location, but there's no reason you shouldn't make sure your existing data directory files are in that location. Starting from some unusual network drive could easily cause problems without their being an actual problem with the database.
Sign In or Register to comment.