Page numbers in citations - LibreOffice; APA6

When adding citations into text the page number formatting does not appear to comply with APA6 convention, despite this being set in preferences.

Instead of (Author, date, p. n) what is being inserted is (Author date:n) - where n signifies page number. Note, commas are also missing.
  • Can you test this in a new document?
    Also, the style is set on the Zotero pane under "Document preferences"?
    Also, try switching to a numeric style and back.
  • Hi thanks.
    I have tested it in a new document - no difference.
    I know that the citation style is set in the Zotero pane under Document Preferences
    I'm not quite sure what you mean by a 'numeric style'. However, switching to APA 7 changes things to the desired citation style; switching back to APA 6 reverts it to the wrong one (using the colon and omitting commas etc.)

    Noting that the Zotero application Preferences indicated the Plugin was not installed (even though it was) I re-installed this. No difference; and the Zotero application Preferences now indicates the Plugin is installed.

    Confused, as it looks simply as though the APA citation style is being implemented incorrectly, even though when I was using it regularly a few years ago it was behaving well.

    In case this is relevant, I have recently updated to:
    Mac OS 10:15 (Catalina)
    LibreOffice 6.3

    Thanks for your support.
  • edited May 1, 2020
    You aren’t selecting APA 6th edition. You are selecting “American _Sociological_ Association 6th edition”. If you need APA 6, you need to install it. Click “Get Additional Styles” in the Cite pane of Zotero preferences and search for it.
  • @bwiernik - thank you for spotting the user error! You are right. And your suggested remedy was quick and smooth to implement.

    Thank you again. 1,000 lines:
    "I must pay attention to detail.
    I must pay attention to detail.
    I must pay attention to detail.
    I must pay attention to detail.
Sign In or Register to comment.