Zotero 5.0 not downloading metadata

Hi There,

I have encountered the following intractable problem: metadata is not downloading correctly when using the Firefox Connector. For example, when accessing library catalogue pages or journal search pages, Zotero does not recognise the record type or any details - it is only recognizing them as webpages and downloading scarce information, page title, URL and date/time added.

I have reinstalled both desktop software and add-on, checked all cookies settings, permissions, tried with/without VPN, restarted, the works.... and have now run out of ideas. Transcribing manually is killing me...

If you could shed some light that would be great...


Firefox 75.0
Zotero 5.0.85
Zotero Connector for Firefox 5.0.64
  • Thanks for the prompt reply.

    I've gone through the troubleshooting list but the fault still persists. The details are as follows:

    >The exact URL of a page that isn't working (even if none are):


    >A Debug ID from the Zotero Connector for a save attempt or, if you're only getting a webpage icon, for loading the page.


    >What it says in the popup when you try to save (e.g., “Saving to My Library” or “Saving to zotero.org”)

    'Saving to My Library'

    >The name of the translator from step 10, if applicable

    Hovering over button does not offer translator info, just 'Zotero is Online'

  • And here is the report ID for recent Save attempts from my library catalogue:

    Thanks, C
  • edited April 23, 2020
    [JavaScript Error: "Zotero.Proxies.proxies is undefined
    Hmm, that's weird.

    Can you 1) disable the extension, 2) re-enable the extension, 3) reload a page to reproduce this, and 4) provide another Report ID?
  • @charlesrobb: Actually, if you go to the Zotero Connector preferences (right-click on the save button and click Preferences), go to Advanced, click Config Editor, click through the warning, what's the value for proxies.proxies? (If it contains private information, you can x it out or email it to support@zotero.org with a link to this thread.)
  • Ok - the value for proxies.proxies in the Config Editor is "[]"
  • And this happens every time? Disabling and re-enabling the extension never fixes it?

    We’d still want a Report ID immediately after enabling and getting this.
  • That's right - disabling and re-enabling seems to make no difference.

    Report ID: 1748887532
  • @charlesrobb Did you try testing with all other extensions disabled in the browser? You might need to go into the Connector preferences and reset translators again.

    Could you also test in a new firefox profile?
  • I sure did. And I've reset the translators several times to no effect! Any further suggestions welcome...
  • Did you try in a new profile?
  • Ha! Creating a new Firefox profile worked. Thanks so much for the help! Presumably I can restore my original Firefox profile so that I don't lose all my keychain data, bookmarks, etc? Advice for next steps welcomed..
  • I would just delete that new profile and then Refresh Firefox in your old profile, which creates a new one while preserving bookmarks and the like. The old one will be placed on the desktop.
Sign In or Register to comment.