how to use zotero in google doc with chromeos

hi I am new to chromeos and finding that zotero is currently available in google docs for citation insertion

however this function requires standalone zotero, this mechanism seems awful for google doc is an online service, with zotero now have cloud version, but requiring an offline desktop client

could google doc's zotero directly link to the cloud one other than the local software? though I use zotero standalone under linux mode for latex bibtex insertion, I think most of the users would like to use the easier google doc for lite documents
  • The citation dialog insertion heavily on Zotero Standalone, not just for the data but also for the user interface etc. I doubt this is going to happen as a cloud only solution.
  • well I still hope this can be happened in the future...zotero standalone seems not a necessary as long as the database is already on cloud
  • I finally get the stuff work under chromeos...

    as long as the zotero connector is running through tcp port 23119, this port is not forwarded to the host chromeos environment under crostini

    what I have done is to install a port forwarding app:

    set forwarding rule as following:
    source: (anywhere) port 23119 (connection port from chrome)
    destination: port 8080 (target port in crostini vm)

    and set the zotero http port to 8080 (default port 23119 will crash the os), this port is arbitary but be careful not crash with other crostini ports, and must the same as the destination port

    in zotero:
    Edit -> Preference -> Advanced -> Config Editor -> Accept -> extension.zotero.httpServer.port -> double click and set to 8080

    enjoy zotero in chromebook!!!!
  • I'm using a Pixelbook and installed Zotero as a Linux app. This was on the edge of my capability, but I got it done. Much to my suprise Zotero did not integrate with Google Docs. Then I found your post. You are a genius! This worked well. I hope the Zotero admins add your instructions to their official "Zotero on a Chromebook" instructions. Thank you.
  • @MFSchar , I had not thought to try installing it as a Linux app on my Chromebook. Out of curiosity, after doing so, does the default Chrome plugin (on the Chromebook's browser) detect and work with the Linux version of Zotero? I wasn't sure if it running the Linux version in it's own sandbox affected the workings between the two.
  • After you follow the port forwarding instructions above, they will work together.
  • Hi,

    I don't get the last part "in zotero:
    Edit -> Preference -> Advanced -> Config Editor -> Accept -> extension.zotero.httpServer.port -> double click and set to 8080"...

    I downloaded zotero and linux, but zotero went to my "downloads" in a "file form".. i am so bad at the computer :'( :'( please help!
  • @agt200 You can install zotero using the following scripts, courtesy of Emiliano Heyns
    wget -qO- | sudo bash
    sudo apt update
    sudo apt install zotero
    Then you can follow jackyko1991's method.
  • Just got a new chromebook. I had this working no problem on my last one, but now I'm getting an error...

    When I try to run sudo apt update I get the following error: "N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository ' llvm-toolchain-stretch7 InRelease' doesn't support architecture 'arm64'"

    Any help would be much appreciated. Need to get Zotero running ASAP.
  • Assuming that indicates your Chromebook is running on an ARM64 processor, I'm pretty sure this won't work. Zotero doesn't run on ARM processors, I'm afraid.
  • I have this same error here with a Levono Chromebook :(

    Skipping acquire of configured file 'main/binary-arm64/Packages' as repository ' llvm-toolchain-stretch-7 InRelease' doesn't support architecture 'arm64'

  • Some follow-up questions on this, for anyone on a Chromebook who's familiar with the issues here:
  • My first post here but wanted to share. I have found another way for this purpose. I am trialing CrossOver for Chrome OS. I installed a browser and Zotero Standalone in the CrossOver VM and used Google doc in the browser. It works a treat.
Sign In or Register to comment.