OO plugin - dead on arrival?

I am running zotero 1.0.10, with OO 3.0.1 on a MAC OSX 10.5.6.

I downloaded the zotero.oxt to run with OO and it is not working. I tried to install the extension and got the following message (bear with me, it's long):
(com.sun.star.uno.RuntimeException) {{Message= "python-loader: exceptions.SystemError:dynamic module not initialised properly, traceback follows\XOOOa Couldn't find uno._uno_extract_printable_stacktrace", Context= (com.sun.star.uno.XInterface)@0}}

While the plugin appeared not to install, I do now have the zotero toolbar on my OO documents though, oddly, it's in words not icons and nothing happens when you click on them.

Any clues as to what's going on will be very much appreciated. I'm absolutely not techie so please keep it simple. Apologies if this has already been covered on the forums. I may have overlooked a solution that I didn't understand!

  • Upgrade to OpenOffice 3.1, remove the plugin, and reinstall it. OO 3.0 didn't support Python-based plugins on OS X.
  • Worked like a dream. Thanks, Dan, especially for the easy-to-follow instructions! Zotero is a wonderful product.
  • In Fedora 11, installation was fine once I installed the openoffice.org-pyuno package using 'yum install openoffice.org-pyuno'. Until I guessed that something was missing the error message was pretty uninformative
Sign In or Register to comment.