zotero.org login failures, endless

The Web browser login for Zotero.org fails.
Again and again, for newly installed browsers.
It won't log in, just keeps asking for the (correct!) username and password, then refusing, then asking again.
Multiple browsers, and operating systems, including fresh installations.

Wiping cookies, and stored login details... Doesn't help.
Install yet another browser? Yes, it works... for a while... then breaks.
Back to square one.
There is no informative error message, nor any other helpful information I can add, just the persistent login dialog, that ignores correct input.

Zotero is the worst for this (so I don't blame the browsers), and has been for years already.
Are Zotero intending to fix this issue, which must be so common?

Must say, other parts of Zotero codebase are good. Only this bit is dire.
  • edited March 3, 2020
    Sorry about that. We pushed an update to the website which seems to have interfered with logins to the forums. We've rolled it back for now. Let us know if you're still having trouble.
    And if you can't log in, please email registration@zotero.org
  • @dcmoffat: To be clear, though, this was a temporary issue that broke some new logins from code rolled out yesterday, not some years-long problem. It's not clear what you're referring to there.

    The new code should fix some cases where you could be logged out after 30 days even if you'd used the site in that time, but that's pretty minor and didn't interfere with normal login to and usage of the site. There's been one other issue for a few users of Safari on macOS, where it seems like Safari's Intelligent Tracking Prevention sometimes misfires and blocks cookies for the forums, and we've rolled out some code that may help with that. We're not aware of any other issues.
  • Okay, that sounds promising.
    Thank you both!

    It's probably the 30 day issue, consistent with fresh browser installations 'working' for a while.

    Will try, and confirm if that works again...
  • Have tried twice, with partial success...

    Works again today (thanks to your website rollback?) on:-
    Android, opera mini browser.

    Still broken on:-
    Android, Firefox beta browser.

    So will use the opera browser for Zotero Web clippings.
    This is a major user case for me, for Zotero.
    Surprised if it's not used by many people, but OK.

    Thanks again.
  • Cannot login on Chrome (windows 10) as of today. OK on same PC using Edge.
  • @bauct Are you also getting a login loop, or some other error?
    Does it still not work if you try in incognito mode?
  • I am getting a login loop. Same in incognito mode
  • I'm having the same problem (Chrome, Ubuntu 16.04).
  • I am having the same problem - looping back to login page - using the native browser on Android 9 (Onyx Book Note 2 device). I could login on a phone using Android 10. It works with a native browser on Android 7. The apps that I want to use to connect to Zotero use the native browser for login, so this blocks the use of Zotero on device that seems well suited for Zotero (A5 sized ereader)
  • @markhampton Is this an app trying to create an API key so it can access your library (using oauth)? Does it also happen if you use the native browser to go to zotero.org and log in from there? Do you know if you have anything installed in the browser or that device that would interfere with cookies (generally privacy related extensions or ad-blockers)?

    Could you try again with that device and then post (I've added some additional logging) and let me know if you're trying to log in to an account other than the one you're posting from.
  • @fcheslack the app ZotEZ2 is trying to access the library, but I am not sure of the details of how it does that, for setup it directs to the Zotero site for login. Yes I get the same problem if I try to login with the native browser. There is nothing installed on the native browser by me. I have tried deleting the cache, deleting the cookies. I tried accessing with this account and the app at around 9h02 in France. Then I tried from the native browser at 9h04. At 9h06 I tried after clearing the broser cache. Thanks.
  • Hello,
    Zoo for Zotero is the app I am using to sync my Ereader with my Zotero library. I enter the correct username and Password but it keeps on taking me to the same Login page.I am having the same Problem I guess with above. I do not have so much knowledge working around APIs and so..
    Did you have Solutions for this ?
  • Yes there is a workaround, you can enter the API information into the App instead of using the login page of Zotero.
  • API information is where? apologies for the lack of competence in this area :D
  • When you launch the app it has an option "Enter your Zotero API Key Manually" and you find that info in your Zotero account Home > Settings > Feeds/API and click "Create new private key".
  • @markhampton THANKS A BUNCH! it worked
  • Can someone that was having trouble with this try again now?
Sign In or Register to comment.