[CSL STYLE ERROR: reference with no printed form.]. juris M

Got this error message when trying to add a citation.

Now all my EU Regulations look different when trying to enter into a new document. Has there been an update to this style which may interfere with my citations?
  • Apologies the document I tested the error in had just plain OSCOLA style that's why the citations looked different.

    Just tried to re-enter the same citation in the document - no error this time however only the suffix I entered came through on the citation in word.

    would this be something to do with repeat references? it is cited for the first time 3 lines above.
  • [CSL STYLE ERROR: reference with no printed form.]

    Keep getting this error code on one particular citation. Deleted the citation in Juris M and re-created it however it won't pull through into my word document. As said above I just get the suffix I enter or the error code above.

    Any guidance on how to fix this?
  • What item type is that particular citation and what style are you using?

    Depending, this error sometimes is shown where that specific item type has nothing set in the citation style. (but there is other sources of this problem, too)
  • Item type is Regulation. I am using Regulations else where in the same word doc and they come out fine. Also the exact same citation is used in my word document a page above and comes out with the full citation and suffix (no style error)

    it is just this one particular citation which doesn't make sense to me. I have deleted it and re inserted (same thing happens) and I have moved it it to trash in Juris M then re created it (still doesn't work)
  • Do you get this error citing that item with this style in a new empty document? If so, can you export the item as CSL-JSON, post the output to https://hastebin.com, and post a link here? Please also do the same with your style code.
  • it worked fine in a new document with OSCOLA JM (same style I am using in other doc)

    what do you suggest I do now?
  • Hi there,

    I have received the same error when using another Regulation citation. I tried it in another word doc and it came out fine.

    There are now two Regulation citations it does this for, the rest seem to work ok.

    What do you suggest i do to get the citation to code correctly in my original document?
  • Are you citing those regulations multiple times?
  • Yes and no.

    The original post on this thread was referring to a citation i have repeated multiple times throughout.

    The citation i tried to insert yesterday was just once. From what i can tell it's not the repeat reference thats the problem, it's the entire thing.

    I tried deleting the entire reference from Juris M and re-creating it but the same thing happened. Anything else i could try?

    Kind regards
  • Can you export the two problem references to CSL-JSON format, then copy the code that is output to https://hastebin.com and give a link here?
  • https://hastebin.com/qaritaluwe.json

    Done - the bottom code is the one that comes up with the error when first inserting the citation. The upper code works on the first citation however the error comes up when repeating the citation.

    I am assuming its due to the fields i have entered the metadata into. I have only done it like this because i cannot find a way of getting the correct citation to populate in my document.
Sign In or Register to comment.