juris M - Zotero

Every time I refresh my word document it says "A copy of Zotero is already open. Only one copy of Zotero can be open at a time."

It only started doing this just now after I tried to create abbreviation filters in Juris M style editor. Can I simply just delete Zotero now im using Juris m or do I need to keep it installed on my Mac so it keeps back ups of my data?
  • just to add on this - the entire thing is not working now! I cannot refresh or add citations!

    Starting to panic slightly as im in the middle of referencing an assignment due at the end of this week
  • I don't know if this solves this problem. Just for better distinguishing between the two applications:
    Juris-m creates a separate database in a separate folder, different from Zotero. Please find the folder path in the preferences: https://www.zotero.org/support/preferences/advanced (default: /users/USERNAME/Zotero and /users/USERNAME/Juris-M)
    If you want to keep the Zotero database as backup, no problem. This should not interfere with Juris-m. The program files are stored in a different locations. You can uninstall Zotero and keep its database: https://www.zotero.org/support/kb/uninstalling. For running Juris-M, you don't need to have Zotero installed.
    Please make sure that you have an up-to-date Juris-M plugin installed in Word (https://www.zotero.org/support/preferences/cite). If you don't use Zotero, you can uninstall the Zotero plugin from Word (see https://www.zotero.org/support/word_processor_plugin_troubleshooting#mac).
  • edited March 18, 2020
    Have you tried restarting your computer? Or depending on your OS, quit the JurisM/Zotero apps, find the still running Zotero job (if there is one) and kill it?
  • edited March 18, 2020
    @Ewelch99: It is as @bkorn says, with one exception: Juris-M and Zotero use the same word processor plugin, so you shouldn't need to touch Word. Restarting your computer as a first step in debugging will assure that neither Juris-M nor Zotero are running, so you start with a clean slate.

    Juris-M and Zotero are separate programs. For normal work, you will use only one of them, but there is ordinarily no harm in having both installed on the same computer.

    On the Mac system I have here, I get the error that you mention when I run Zotero and then attempt to start Juris-M, and also vice-versa. When Juris-M is closed, and I attempt to add a citation to a document, Word wakes up Juris-M. I can't reproduce the exact behavior that you describe, but what appears to be happening is that one application is running, and your Word is attempting to start the other. That should not happen, but as an immediate solution, you can uninstall Zotero as suggested by @bknorn. (If you have items stored in Zotero, removing the application will not affect the Zotero-side database: it will be accessible when you reinstall Zotero.)
  • It has been working fine for me since resetting. If it happens again I will delete the Zotero app on my Mac.

    thanks for your help
  • my data dictionary location on Juris M is set to custom - users/myuser/Zotero

    the Juris M one above it is the default, should I be using that instead?

    As you said Frank, word keeps trying to open Zotero when I have Juris M open, can I simply just delete the Zotero app without effecting my Juris M database?
  • This may be fixed, in release 5.0.83m6. Your client may already have updated, if not you can pull in the changes with Help -> Check for updates.

    Jurism was using an outdated version of the Zotero word processor plugins. As a result, the word processor plugin was unable to contact the Jurism client, which may have triggered the behavior that you were seeing.

    Separately, if you don't need Zotero for your work, it is safe to remove it.
Sign In or Register to comment.