Library won't load because of Zotero error

I was trying to add a document to my library and suddenly I got a error message pop up that says: "Received error from Zotero server: '31' is not a valid field for type 'document'."
Now my library has a perpetual loading symbol instead of my entries. I've tried logging out and in, a different browser, everything.

How do I get my library back
  • Can you provide a Debug ID for Zotero startup using the "Restart with Logging Enabled…" option?

    If you check your database integrity from the Advanced → Files and Folders pane of the Zotero preferences, does it pass?
  • I think the Debug ID is D955355846.

    I can't seem to check the database integrity. I am using Zotero from Chrome.
  • edited February 6, 2020
    I actually misread your post. It sounds like you don't have the Zotero app open on your computer while trying to save and are trying to save directly to the online library. That should work, and we'd be interested in a Debug ID from the Zotero Connector that shows you loading a page, saving, and getting that error, but you also would ideally be using the local Zotero app instead of saving to the online library.

    When you say "Now my library has a perpetual loading symbol instead of my entries", that's also referring to the online library? Do you know if you're using the old web library or the new beta one?
  • I have only used the online library and have been saving files onto that. I am not sure how to tell which version I am using!
  • We'll look into the error you're getting in the online library, but if you can install software on your computer, you should install Zotero from the download page. (When people refer to "Zotero", they're almost always talking about the actual program you run on your computer. The Zotero Connector saves to the program by default, and the program syncs with your online library and other computers.)
  • I forgot I had already downloaded the app and was working on it a year ago under a different log in. When I open the app now, it takes me to that library. Is there a way to log out and get onto a different library?
  • Ok-- I figured out how to do that. But now it says that all data from that account will be removed from this computer. If I need it later, can I just re-sync it?
  • Yes, if it's fully synced with that account, but you'd want to make sure all your data was available online in that account. And I would still recommend making a backup of the Zotero data directory for good measure before wiping it.
  • Hi! I'm having a similar problem loading my online library. I'm getting the following message: "Received error from Zotero server: '91' is not a valid field for type 'report'."

    I've tried coming back to the library many times throughout the day, and the issue won't seem to go away. Is there a way for me to access my library without downloading Zotero locally?
Sign In or Register to comment.