Feature request: Hover over citation code fields in Word doc to see contents

Hello -- Would save a lot of time if we could hover the cursor over inserted citation code fields to see the contents before opening the plug-in to see them in Edit Citation.

(I'm using Zotero plug-in for MS Word 2008 Mac.)
  • Citations are just standard Word fields — we don't have control over what's displayed when you hover over them.
  • Is there a way we can get a preview of the citation contents without opening Edit Citation?
  • I assume you mean when using a numeric style? The easiest thing to do is just to edit the document using an author-date style and switch back to the numeric style at the end.
  • That's a good idea. Where is the setting for date style?

  • You can change citation styles under "Document Preferences".
    American Psychological Association or Chicago (author-date) are common, pre-installed author-date styles.
  • The journal wants SAGE Vancouver style.

    In Document Preferences, I have radio buttons for only Fields or Bookmarks in SAGE Vancouver or APA style. I have been using Fields, which insert superscript numbers for citations.

    In the Style Editor for APA, I see code for .

    If I set the style for APA, do I then regenerate the citations? How do I do this?

    Can I easily switch to SAGE Vancouver later? Do I need to regenerate citations after switching back?

    I'm in the middle of this paper, if I lost my citations now, I'd lose my mind.

    PS In the Style Editor for SAGE Vancouver, I see code for . Should I edit this instead? If so, is the syntax "author-date"?

  • edited February 23, 2020
    When you change citation styles in the Document Preferences window in Word, all of your citations will be changed to the new style. You can always change back later when you are done writing and Zotero will change all the citations back to Sage Vancouver.

    I would recommend not trying to edit the style if the purpose is just for you to see your citations as you write. Just change to a style that is already author-date.
  • I changed the citation style to APA, nothing happened to change the citations already in the document.

    I had to Refresh to get the document to display APA author-date citation style.
  • That would be the case if you have "Automatically update citations" disabled in the document preferences. Otherwise it will update them as soon as you click OK.
  • I've run into a bug -- I changed the setting to APA, refreshed, the citations updated to author-date in only the first 3.5 pages of 17 pages.

    I enabled "Automatically update citations", the above did not correct. I Refreshed, the above did not correct.

    I saved and closed the Word document, reopened it, refreshed. Author-date citations were inserted in 12 of 17 pages. Rinse, repeat, author-date citations were updated in the rest of the document.
  • See the last step on Debugging Broken Documents. If you can reliably reproduce the problem of only some citations updating when you change the style in an excerpt of the document, send it to support@zotero.org with a link to this thread and we'll take a look.
  • Word progressively updated the fields after each operation sequence.

    If I remember correctly, this is not unusual behavior for Word, I think I've run into it years ago pre-Zotero.
Sign In or Register to comment.